Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Gujs : i agree with you. It's the reason why i use your ppa. SVN is really unstable.
>SVN is really unstable
+1

svn:30871
PC1 (OLD with SSE1): compilation OK, run -> crash - no debug,nothing
PC2 (NEW PC): compilation OK, run and after x second crash (segmentation...)
I have just submitted a patch to trac http://trac.xbmc.org/ticket/9414
You can expect new build in my ppa until tomorrow morning.
hehe! just wanted to ask, why this patch has not been applied in your sources.

Index: addons/pvr.hts/resources/settings.xml
===================================================================
--- addons/pvr.hts/resources/settings.xml (revision 30781)
+++ addons/pvr.hts/resources/settings.xml (working copy)
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<settings>
- <setting id="host" type="text" label="30000" option="urlencoded" default="127.0.0.1" />
+ <setting id="host" type="text" label="30000" default="127.0.0.1" />
<setting id="http_port" type="integer" label="30001" default="9981" />
<setting id="htsp_port" type="integer" label="30002" default="9982" />
<setting id="user" type="text" label="30003" default="" />
<setting id="pass" type="text" label="30004" option="hidden" default="" />
+ <setting id="skip_I_frame" type="bool" label="30005" default="true" />
</settings>

took me an hour to figure out why host is always unknown. By the way something like this would be realy useful:

------------------
in HTSPData.cpp
------------------

bool cHTSPData::Open(CStdString hostname, int port, CStdString user, CStdString pass, long timeout)
{
XBMC->Log(LOG_DEBUG, "cHTSPData::Open - host %s", hostname.c_str());
This is now in my new build from this night.
I can't login to the web UI, always gives me a 401

already reconfigured the package, tried other user&password, even left blank

I installed the deb package, in the meantime also tried to manually start tvheadend from the console with -C
tvheadend tells me it has created default wide open access entry but still 401 when trying to login

any ideas?
Gujs Wrote:This is now in my new build from this night.

With this version scheduling doesn't work for me. Always when I add a timer for a future program it starts recording the actual program of the same channel. For me the previos version was better although i have to reload de EPG at restart to work properly.
xbmcuser2000 Wrote:With this version scheduling doesn't work for me. Always when I add a timer for a future program it starts recording the actual program of the same channel. For me the previos version was better although i have to reload de EPG at restart to work properly.

I have to describe it more precisely. Most of the time xbmc marks the program RIGHT BEFORE the one i want to record. Deleting of the marked program works though.
It was a stupid mistake. I already fixed the problem. But don't have space left on ppa, so I have to wait that previous packages are deleted before I upload new one. I hope I can start upload before I am going to sleep, so that it will be on ppa until tomorrow morning.
Hannes The Hun Wrote:I can't login to the web UI, always gives me a 401

already reconfigured the package, tried other user&password, even left blank

I installed the deb package, in the meantime also tried to manually start tvheadend from the console with -C
tvheadend tells me it has created default wide open access entry but still 401 when trying to login

any ideas?

make sure ports are open. in ubuntu command is 'ufw allow 9981'
DanXbix Wrote:make sure ports are open. in ubuntu command is 'ufw allow 9981'

thanks a bunch, dan! this and another dpkg-reconfigure hts-tvheadend did the job! Cool
In france, there is 3 TV channels that have the sound encoded in eac3. It seems that it is not supported by XBMC ?! I don't think it is a probleme a PVR itself but more with XBMC.

Some patches are availalble for ffmpeg to take into account eac3.

Does xbmc link to ffmpeg or use ffmpeg as lib ? In other words, if i install in my ubuntu lucid a patched version of ffmpeg, could eac3 channel work ?

nunu
is timeshift planned for the next xbmc final release?
Hi guys . I have a Zotac ion. is there any settings i need to set to get HD channels working mine are in slow motion..
with audio out of sink.
Purple8 Wrote:Hi guys . I have a Zotac ion. is there any settings i need to set to get HD channels working mine are in slow motion..
with audio out of sink.

Have you tried the latest Tvheadend version + Latest XBMC-PVR version of Gujs? Should use VDPAU now. So when you have the latest PPA version's see the CodecInfo screen and look if VDPAU is being used. Also see if CPU is 100%.


Ps. For the audio out of sink problem you should consult a plummer i guess.. Smile