Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
moontan77 Wrote:I'm using the latest build of xbmc on gujs's site which is about 3/4 weeks old. Vdpau is working fine for most channels, its just these bbc hd channels which are a problem and it looks like its just the tvheadend side of things which is the problem. I attached a muxdump with my ticket so hopefully andoma gets to look at it.

Hi. Can you look into the tvheadend configuration file for that channel. You will find the size of video in that file. If it is wrong than tvheadend has the problem. Here is a sample from one of my configured channel:
Code:
cat /home/hts/.hts/tvheadend/dvbtransports/_dev_dvb_adapter0_STB0899_Multistandard11953500_H_satconf_1/_dev_dvb_adapter0_STB0899_Multistandard11953500_H_satconf_1_6d66
{
    "service_id": 28006,
    "pmt": 100,
    "stype": 1,
    "scrambled": 0,
    "channel": 0,
    "provider": "ZDFvision",
    "servicename": "ZDF",
    "channelname": "ZDF",
    "mapped": 1,
    "pcr": 110,
    "disabled": 0,
    "stream": {
        "pid": 110,
        "type": "MPEG2VIDEO",
        "position": 0,
        "width": 720,
        "height": 576
    },
    "stream": {
        "pid": 130,
        "type": "TELETEXT",
        "position": 1
    },
    "stream": {
        "pid": 120,
        "type": "MPEG2AUDIO",
        "position": 2,
        "language": "deu"
    },
    "stream": {
        "pid": 121,
        "type": "MPEG2AUDIO",
        "position": 3,
        "language": "2ch"
    },
    "stream": {
        "pid": 125,
        "type": "AC3",
        "position": 4,
        "language": "deu"
    },
    "stream": {
        "pid": 131,
        "type": "DVBSUB",
        "position": 5,
        "language": "deu",
        "compositionid": 1,
        "ancillartyid": 1
    }
}
yep tvheadend seems to be the issue:

{
"service_id": 6941,
"pmt": 260,
"stype": 25,
"scrambled": 0,
"channel": 0,
"provider": "BSkyB",
"servicename": "6941",
"channelname": "BBC 1 HD",
"mapped": 1,
"pcr": 5400,
"disabled": 0,
"stream": {
"pid": 5400,
"type": "H264",
"position": 0
},
"stream": {
"pid": 5402,
"type": "MPEG2AUDIO",
"position": 1,
"language": "NAR"
},
"stream": {
"pid": 5403,
"type": "TELETEXT",
"position": 2
},
"stream": {
"pid": 5404,
"type": "DVBSUB",
"position": 7,
"language": "eng",
"compositionid": 1,
"ancillartyid": 1
},
"stream": {
"pid": 5401,
"type": "AC3",
"position": 19,
"language": "eng"
},
"stream": {
"pid": 9080,
"type": "TEXTSUB",
"position": 1000,
"language": "eng",
"parentpid": 5403
}
}
@moontan77
it looks like andoma already fixed that issue for you. I will try to upload new tvheadend build tonight.
thanks Gujs, it works fine now.
CrashX Wrote:It looks like your maintaining changes for both xbmc and tvheadend ? Are you syncing your changes to latest trunk for both ?
yes & yes, everything is up to date up till the last commit.
Quote:When you do think they will me merged into the trunk ?
don't know, if you're talking about the patches to tvheadend: when/if andoma thinks it's time to merge them Smile if you're talking about the changes to xbmc: don't expect anything to be merged before dharma is finished and merged.

Quote:I just built both xbmc and tvheadend off the trunk and wanted to know what exactly will I get if I use your patches ? Do you have patches to apply on the trunk ?
my patches to tvheadend are on it's trac, tickets 299 and 300.
If you want to get the patched sources of xbmc, just get them from github: http://github.com/opdenkamp/xbmc
All the changes can be found there. I recommend you take the Dharma-pvr branch there, not master/trunk.

Gujs Wrote:@moontan77
it looks like andoma already fixed that issue for you. I will try to upload new tvheadend build tonight.
should have been fixed in my builds too
Hey.

I just tried the quick installation of lars-opdenkamps ppa.

sudo apt-get remove -y xbmc xbmc-bin xbmc-data xbmc-skin-confluence
sudo apt-get install -y python-software-properties
sudo apt-add-repository ppa:lars-opdenkamp/xbmc-pvr
sudo apt-get update
sudo apt-get install -y xbmc

Since I'm running a HDD installation from the Live CD (Dharma 3), I don't have a desktop.
The way I launch xbmc is with xinint xbmc and this does not work with the version provided in lars-opdenkamps ppa.

Am I missing something?

/Chris
Cribbe6 Wrote:Hey.

I just tried the quick installation of lars-opdenkamps ppa.
<snip>
Am I missing something?
if you're using the stand alone version of xbmc, be sure to install it's package:
Code:
sudo apt-get install -y xbmc-standalone

(btw, Lars Op den Kamp = me, so you can address me for issues with it)
That makes sense.
I will try it tonight.

/Chris
dushmaniac Wrote:if you're using the stand alone version of xbmc, be sure to install it's package:
Code:
sudo apt-get install -y xbmc-standalone
Hi,

I run a ubuntu server 10.04 LTS, I run xbmc using the following package:
sudo apt-get install xbmc-live.


I am not using (as far as I know) the xbmc-standalone package. Can you tell me what the difference is?

regards,
Ruud.
Ruud Wrote:I am not using (as far as I know) the xbmc-standalone package. Can you tell me what the difference is?
you are using the xbmc-standalone package too.

from the rules file:
Code:
Package: xbmc-live
Architecture: any
Depends: xbmc-standalone (= ${binary:Version}),
         policykit,
         openssh-server,
         ${python:Depends},
         python-apt,
         adduser,
         sudo,
         whois,
         ${misc:Depends},
         ${shlibs:Depends},
Conflicts: kdm, gdm, xdm, wdm
as you can see, xbmc-standalone is installed by the xbmc-live package too.
a new build of tvheadend has been sent to my xbmc-pvr ppa:
- fixed amd64 build
- updated to svn rev. 5515
- patched so it reports the signal status and CAID

the build for lucid has just been published. maverick will follow later.
Gujs Wrote:@moontan77
it looks like andoma already fixed that issue for you. I will try to upload new tvheadend build tonight.


Hi Gujs. I have updated to your latest build of xbmc (karmic build) and now my pc no longer boots into xbmc. This is the first time i've had a problem upgrading to a newer build from you. The screen goes white and nvidia logo also appears for a second (which never happened before i updated this evening) and it eventually stops at the login screen. Xbmc-standalone is installed.

Is there any way for me to revert back to your previous build?

(i did not upgrade nvidia drivers, all that was upgrading was the xbmc files)



edit: commented out your source and just installed the xbmc svn and that booted ok. Seems like there is some issue with our build for me anyways (i'm using an nvidia ion acer revo pc)
you might want to put (a part of) the contents of your log files in that post.
Hi,

running versions as stated in signature I run into the following problem:
1. from EPG select current running program and press OK > record
>> recording starts (as it is supposed to)
2. then from Timer select running recording and deselect ACTIVATE > OK
>> information message: "PVR-server is not compatible... Try again"

** note: running multi seat setup **

can somebody reproduce?
Thanks,
Ruud.
Hi,

running versions as stated in signature.

1. on tvheadend web interface start a recording
>> in XBMC recording title shows in timer list
>> in XBMC recording title shows in tv home screen
>> in XBMC tvguide program shows a red dot (being recorded)
>>> so far so good

2. on tvheadend web interface stop recording
>> in XBMC recording still shows recording tile in timer list as currently recording
>> in XBMC recording still shows recording tile in tv home screen as currently recording
>> in XBMC tvguide program still shows a red dot
>>> this is not how you expect it to be...

** note: I run a multi seat installation **

can anybody confirm this issue?

thanks,
regards,
Ruud.