Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@Ruud:
I'll have a look at that today. Anything that changed can be found in the changelog.

xoox Wrote:Perhaps related to http://trac.lonelycoder.com/hts/changeset/5318
That changeset caused it indeed. Fixed it on git. It'll be included in my next ppa build.

@anyone building manually from git:
remove your Addons.db after commit 1683bdc1fffa20adf04b or you won't be able to enable your pvr addons. you could also update the version number to '13' using sqlite.
Found the cause of the EPG offset problems too. Will be fixed later today.
dushmaniac Wrote:Found the cause of the EPG offset problems too. Will be fixed later today.

Just got a mail via the hts-devel mailinglist:
Quote:I've fixed so Tvheadend seeks back and writes the correct segment
size once the recording is done. Also, I've changed a bit what
Tvheadend writes there initially (ie, during the actual recording)
and it seems that some players are more forgiving about the new
way I write 'unknown size'. FFmpeg 0.5 no longer crashes with
floating point errors.

All done in r5555

Hopefully this will fix your problems.

Looks like Santa Claus has arrived early Rofl

will be testing later on, first have to wait till some recordings are finished.

thanks,
Ruud.
thought I had already subscribed to the mailing list but apparently I didn't. fixed Smile
can anyone recommend a dvb-s2 usb tuner?

Have two technotrend s2-3600 tuners which give non stop continuity count errors (just googled and seems like its a common problem with no solution). And have two tevii s660 which are very slow to change channel and give dts continuity count errors. So I wont be buying those again!

Have two tevii s650 which work perfectly but they are no longer for sale.
dushmaniac Wrote:Found the cause of the EPG offset problems too. Will be fixed later today.

Dushmaniac, thanks for your work on this! One request though. If you make any changes and put them on your PPA, can you list somewhere if you made the fix in TVHeadend or in XBMC/PVR? My server runs Fedora, so I can't use your PPA for TVHeadend. Instead I have to build from svn and patch the source with your fixes before I build it (your explanation on how to do that on page 103 worked well btw). Would be much appreciated.
dushmaniac Wrote:Found the cause of the EPG offset problems too. Will be fixed later today.
a fix has been commited to git and will be included in the next version on my ppa, later tonight or tomorrow.

if you;re impatient and are building from git, clear the epg database or the times will be off.

martdj Wrote:<snap>
it's fixed in xbmc. the latest sources can be grabbed from git://github.com/opdenkamp/xbmc.git .the builds on my ppa are from the Dharma-pvr branch. please note that this is NOT the official XBMC git but a (temporary) fork until pvr-testing2 is merged to trunk (because that's what this fork is, a merge of pvr-testing2 to trunk and a backport to Dharma, including some fixes for the tvheadend addon)
if you used these sources before and are upgrading, delete your Addons.db or manually update it's version to 13.

the only changes I made in tvheadend can be found on it's trac: tickets 299 and 300 (and some other but that one's for the debian package)
I am interested in a recommendation as well.
Thank you moontan for your hint, but one more question. I always have drops in XBMC when watching HD. I do not have drops when watching HD materials like MKV or untouched BluRay. The VDPAU works fine.
Do you have similar problems with your s2-3600? I can watch SD without a problem but HD is always juddering and as I said, I have a lot of drops.
When I am recording a HD channel using the TVHeadend web frontend and play it in XBMC or another box (e.g. Mede8er, Popcorn Hour) I have the same problems with juddering playback.
Is it the same for you or anyone else. Maybe there is another USB box that works fine.


moontan77 Wrote:can anyone recommend a dvb-s2 usb tuner?

Have two technotrend s2-3600 tuners which give non stop continuity count errors (just googled and seems like its a common problem with no solution). And have two tevii s660 which are very slow to change channel and give dts continuity count errors. So I wont be buying those again!

Have two tevii s650 which work perfectly but they are no longer for sale.
dushmaniac Wrote:<snap> :-)
Thanks for the clarification!
the new ppa build I promised will arrive later today because launchpad was b*tching again.
good that there is a launchpad, cause I would have too much spare time if it weren't there!

edit:
packages have been uploaded and are awaiting publication

changes:
Code:
* tvheadend addon: fix EPG content type
  * tvheadend addon: EPG content type and subtype in debug log instead of
    the raw combined value
  * tvheadend addon: fix EPG time offset bug
  * merged with the current Dharma svn. 35113

if you were using an earlier version of my ppa packages, run /usr/bin/update-xbmc-dharma-pvr.sh before starting xbmc or pvr addons will fail to start. you should do this for every user that uses xbmc. you could also remove ~/.xbmc/userdata/Database/Addons.db.
@dushmaniac

Can you add tvheadend build for maverick. When I add your ppa with to version (lucid for tvheadend and maverick for xbmc) i get a error. Every time i have to remove ppas. Clear directory. Add one install one and repeate again.
there is a build for maverick on there. you might not have the right sources set or some ppa you have uses a higher version number than mine according to ubuntu.

first remove any ppa you have that provides tvheadend. next do this:
Code:
sudo add-apt-repository ppa:lars-opdenkamp/xbmc-pvr # add the correct ppa
sudo apt-get update # update apt
sudo apt-get remove -f hts-tvheadend # remove any previous version of tvheadend so version numbers won't complain
sudo apt-get install -f hts-tvheadend # install the new tvheadend

the version should read SVN-r5558~odk2 after installing
Yeah you right. I accidently re enable old ppa for other pvr version of another user. After cleaning all ppas and readding your all problem solved. I think i will never have a update problem four you ppas. Thanks again.


Edit: Anybody know Tvheadend newcamd client name. I'm asking newcamd provider can see which applications connecting server. Acamd, MGCamd etc. When tvheadend connected a server what name is apper on server application.
I have just updated to your new build, dushmaniac, and the EPG data is now one hour delayed. If one program starts at 22:00 the EPG timeline in XBMC shows that starts at 23:00. I have reload the EPG database but the problem persists. Tvheadend shows it correctly. I doesn´t use xmltv sources.

The local time here is UTC +1.
xbmcuser2000 Wrote:I have just updated to your new build, dushmaniac, and the EPG data is now one hour delayed. If one program starts at 22:00 the EPG timeline in XBMC shows that starts at 23:00. I have reload the EPG database but the problem persists. Tvheadend shows it correctly. I doesn´t use xmltv sources.
could you check your log, how the first couple of lines after the first call to GetTime() look?
eg:
Code:
18:49:40 T:3078985600 M:1721233408   DEBUG: AddOnLog: xbmc.pvrclient/Tvheadend HTSP Client: cHTSPData::GetTime()
18:49:40 T:3078985600 M:1721233408   DEBUG: PVR: Tvheadend HTSP Client/192.168.64.1:9982 - Using a timezone difference of '60' minutes to correct EPG times
18:49:40 T:3078985600 M:1721233408  NOTICE: PVR: PVRManager started. Clients loaded = 1

could you also tell me in what timezone you are?

edit:
ok, you already added your timezone now Smile you cleared your EPG database and reloaded? because I'm in the same timezone here (last week +0200, now +0100) and the EPG are correct.
I assume you got a recent tvheadend too?