Kodi Community Forum

Full Version: Restrictions on sounds.xlm and startup.wav?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey,

Been playing a bit with XBMC and thought it would be cool to play some tunes when I start it, instead of the skin default or nothing at all, so i checked the wiki and XBMC file structure and it seemed pretty straight forward, xbmc is playing startup.wav when a session is open, logic.

Knowing this I took my favorite cd and ripped a track to startup.wav and I copied it over the existing file, which seems the right thing to do, but unfortunately when I start XBMC the file is not playing.

The file is playing fine in media players, it has the right name and it's in the right folder, I also took a look at sounds.xlm and it doesn't seems to need any update:

<windows>
<window>
<name>startup</name>
<activate>startup.wav</activate>
</window>
<window>
<name>0</name>
<deactivate>-</deactivate>
</window>
<window>
<name>4</name>
<deactivate>-</deactivate>
</window>
</windows>
</sounds>

this looks correct to me.

So I'm wondering if the wav need something specific, right now it's quite big 90mb and long 9min, I tried to compress it more down to 12mb but doesn't change anything.

Any ideas?
anyone?
Which skin are you using ?
I just tried it with PM3.HD and a 37MB wav file, no problem here.
Only noticed the file will stop as soon as you hit one of the navigation keys.

The audiofile is launched when the startup window (Startup.xml) is active, so check if there's a Startup.xml file present in the skin directory.
Just in case you're running Linux / OSX, you'll need XBMC r20561 or up for this to work.

Also try if it works with this code, it will start the soundfile everytime the home window is opened:
Code:
<window>
      <name>home</name>
      <activate>startup.wav</activate>
    </window>
ronie Wrote:Which skin are you using ?
I just tried it with PM3.HD and a 37MB wav file, no problem here.
Only noticed the file will stop as soon as you hit one of the navigation keys.

The audiofile is launched when the startup window (Startup.xml) is active, so check if there's a Startup.xml file present in the skin directory.
Just in case you're running Linux / OSX, you'll need XBMC r20561 or up for this to work.

Also try if it works with this code, it will start the soundfile everytime the home window is opened:
Code:
<window>
      <name>home</name>
      <activate>startup.wav</activate>
    </window>

I'm using aeon and it's not working are you using a CD-Rip if so which application did you used?