Kodi Community Forum

Full Version: [RELEASE] Luemmel's DVD-Ripper (Script) for Linux, Mac, and Windows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
Go inside the settings of the addon and replace xbmc@localhost with mylin@localhost and you'r on the road again...
linuxluemmel Wrote:Go inside the settings of the addon and replace xbmc@localhost with mylin@localhost and you'r on the road again...

yup Smile that did it. it started and i will test now, but i got this msg "license key for makemkv expired" ?!
In this case I would replace your licence key ;-)

* If you receive the Message "Licence-key for makemkv expired" inside the addon You have to replace your current licence-key with a valid-key.

You can set the licence key here :

user@xbmcdev:~$ cd .MakeMKV/
[email]user@xbmcdev:~/.MakeMK[/email]V$ ls -al
total 16
drwxr-xr-x 2 root root 26 2010-07-10 18:01 .
drwxr-xr-x 45 user user 8192 2010-08-23 21:58 ..
-rw-r--r-- 1 root root 187 2010-08-23 20:57 settings.conf
[email]user@xbmcdev:~/.MakeMK[/email]V$

Inside the file settings.conf the licence key can be updated or deleted.

This section is also inside the faq :
http://code.google.com/p/swiss-army-knife/wiki/FAQ
linuxluemmel Wrote:In this case I would replace your licence key ;-)

i really didnt look into this makemkv yet so i have no clue if anywhere it says it requires a license key Blush

but now im testing to rop a dvd to iso and i get this msg "File swiss-army-knife/media/state could not be opened"
enable verbose debug inside the addon-settings and have a look into xbmc.log
You may see the line increase timeout on line ;-)
Or you can wait until I release 0.6.14 in this case all timeout values are changeable over the settings ...
linuxluemmel Wrote:enable verbose debug inside the addon-settings and have a look into xbmc.log
You may see the line increase timeout on line ;-)
Or you can wait until I release 0.6.14 in this case all timeout values are changeable over the settings ...

dont know if this means anything:
Code:
82352 M:773607424  NOTICE: [swiss-army-knife]: [OSlog]  Timeout 20 secounds reached for track-file  ...
00:35:54 T:2773482352 M:773607424  NOTICE: [swiss-army-knife]: [OSlog]  increase timeout value on line 362 / Linux.py  ...

follow-up:

i actually tried the the iso rip command from shell as follows:
Code:
sudo ssh mylin@localhost /home/mylin/.xbmc/addons/script.video.swiss.army.knife/shell-linux/dvd-iso.sh /dev/sr0 /dvdrip change-me.iso

and it start working

but if i tried to run the command without sudo it gave me permission denied, so i ran it with sudo and it asked for the mylin password and then for the mylin@localhost and then started the rip!!

i also tried changing the timeout on line 362 but nothing happened
There must be something wrong with your ssh server or client ....
If you give the command ....
Code:
ssh mylin@localhost

There should never come up a password to enter .... NEVER ...

All the code in the script do relay on this fact.This was the main reason
to be certain that setup.sh is executed.The setup script do create the keys
for the communication with the ssh-server without any password ...

Inside the expert-mode (1234) is a menu-point test ssh-connection ....
Could you please test this over the addon ?

If this test is not successfull we know that the setup script did not properly
configure the ssh-server .....

What version of Ubuntu are you using ?
Cheers Hans
Luemmel

Thanks for what's shaping up to be a great great addition to xbmc. I am in exactly the same situation as MegaCrypto. I have successfully run the setup.sh and changed the user to my username as opposed to XBMC. Now I also receive the message 'INFO: File swiss-army-knife/media/state could not be open...'.

I have increased the timeout but this brings no success. I have successfully tested ssh as you advised MegaCrypto and this works fine. I have also logged on as myself@localhost and no password is requested. I am using ubuntu 10.04.1 LTS and XBMC 10.0-beta1 r33324.

Any advice would be greatly appreciated.

Niko.
nikovanbasten Wrote:Luemmel

Thanks for what's shaping up to be a great great addition to xbmc. I am in exactly the same situation as MegaCrypto. I have successfully run the setup.sh and changed the user to my username as opposed to XBMC. Now I also receive the message 'INFO: File swiss-army-knife/media/state could not be open...'.

I have increased the timeout but this brings no success. I have successfully tested ssh as you advised MegaCrypto and this works fine. I have also logged on as myself@localhost and no password is requested. I am using ubuntu 10.04.1 LTS and XBMC 10.0-beta1 r33324.

Any advice would be greatly appreciated.

Niko.

OK we try to solve the problem ......

1.) We are talking about release 0.6.13 right ?
If you do not use 0.6.13 upgrade to version 0.6.13

2.) the state file is a single file that contains information about
the inserted medium.

This file should be here :
Code:
config[30] = os.getenv("HOME") + '/.xbmc/userdata/addon_data/script.video.swiss.army.knife/media/state'

The file is called state and should be inside the xbmc-addon directory ..
/script.video.swiss.army.knife/media

You should have full write access to this directory ....

3.) To generate the expected file we have to run the script state.sh

Go direct to shell-linux and execute the following command ....
Code:
./state.sh /dev/sr0

The output should look like this ....
Code:
user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$ ./state.sh /dev/sr0

      ---------------------------------------------------------------------
      script    : state.sh
      version   : 0.6.11 [swiss-army-knife addon]
      copyright : (C) <2010>  <[email protected]>
      changed to /home/user/.xbmc/addons/script.video.swiss.army.knife/shell-linux
      ---------------------------------------------------------------------

      INFO [media:[DVD-ROM]]

      ----------------------- script rc=0 -----------------------------
      -----------------------------------------------------------------
      user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$

BTW : A summary of all shell-scripts can you find on the project-url

http://code.google.com/p/swiss-army-knif...LinuxShell

By now we should have this file called state ......

If we do not have a state file after execution of the above command then is something wrong ....
Inside the script state.sh you should not see any error or warning .....

Could you please check this steps until here ?
i tried the
Code:
ssh mylin@localhost

and it opened the shell with no asking for password, but when i tried to run the
Code:
./state.sh /dev/sr0


this is what i got:

Code:
mylin@MyLinServer:~$ cd .xbmc/addons/script.video.swiss.army.knife/shell-linux
mylin@MyLinServer:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$ ./state.sh /dev/sr0

----------------------------------------------------------------------------
script    : state.sh
version   : 0.6.13 [swiss-army-knife addon]
copyright : (C) <2010>  <[email protected]>
changed to /home/mylin/.xbmc/addons/script.video.swiss.army.knife/shell-linux
----------------------------------------------------------------------------
ERROR! "makemkvcon" is missing. ./state.sh requires it to operate.
Please install "makemkvcon".
----------------------------------------------------------------------------

----------------------- script rc=2 -----------------------------
-----------------------------------------------------------------

although i got no errors when running the setup.sh script.


update:

i think for some reason makemkv is not being installed .. i can't find the .makemkv dir ?

update:

going into the setup.sh to manually install the makemkv i did the wget and got the makemkv-v1.5.8-32.tar.gz, but when i try the next line i get:
Code:
mylin@MyLinServer:~/packages$ tar xvzf makemkv-v1.5.8-32.tar.gz

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors

update:

got it running .. i manually extracted the files using winrar on my windows pc and then copied the two files back to my xbmc box and installed the two deb files. now im testing a dvd rip to iso and looking at the progressbar Smile

also, i guess because makemkv was not properly installed before, this is why i got the license key msg, because now i did not get when i started the addon
OK I will try to integrate a test for the binary makemkv ...
Thanks anyway ...
I will try to find out how this situation will happen.
Cheers Hans

PS : My addon is still in a ALPHA state ....
no thank you Smile i got it working and the rip went just fine Smile cheers
OK I found the bug ....
the tar file for makemkv was not produced with "tar cvzf " it was called with "tar cvf" and therefore the setup will fail ....
I change it .... in 0.6.14
Ok I uploaded a new file for makemkv 32 bit and this time the z flag was included ....
By now you can run setup and it should install the makemkvcon binary without problem.

But I found also a other problem .....

If you did decided not to install the bluray part and only use the dvd-part you still have
big bug inside the addon .....

This is the code from state.sh

REQUIRED_TOOLS=`cat << EOF
dvd+rw-mediainfo
awk
head
lsdvd
makemkvcon
EOF`

You should change it to :

REQUIRED_TOOLS=`cat << EOF
dvd+rw-mediainfo
awk
head
lsdvd
EOF`

Because the binary makemkvcon is not found, the state file do not execute properly ...
And you can not rip dvd's :_(

I do release 0.6.14 on the weekend but it is still a alpha ....
Regards
Hans
Hans

Thanks for responding so quickly. I'll give your suggestion and what MegaCrypto did a bash this evening. I may just wait for the weekend release though... Incidentally, I am on the latest version but I chose not to install the bluray component so perhaps that was the issue all along...

You mentioned that you "uploaded a new file for makemkv 32 bit" - will the weekend release include a fix for 64 bit too?

No need for the apologies of it being an alpha, that's fully understood. Really appreciate the effort.

Regards

Niko
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44