Kodi Community Forum

Full Version: [RELEASE] Luemmel's DVD-Ripper (Script) for Linux, Mac, and Windows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
When I execute Transcode DVD a small wiating symbol appears and then the program terminates.

I enabled debugging for the script, but there is only a logfile (ssh-log)with:
dvd0.sh /dev/sr0

Any Idea how I could get more information whats going wrong?
Yes ,-)
Copy your xbmc.log to a pastebin and may also your settings.
Can you execute the command xbmc@localhost without any password ?
There is a test command inside the expert-mode.
linuxluemmel Wrote:Inside the startup of the script I do look for all the folders that are defined inside
the settings.
Inside the shell-linux folder is a script called check-mkv.sh
Please run this file and report back the output ...
..
From this, I got the same "unexpected operator" error I had before. Now, I changed my default shell to bash and that error is gone. So far so good...

linuxluemmel Wrote:You changed your new directorys to the folders inside your home-dir over the settings ?..
The folders wer not created by the script, so I created ~/dvdrip/bluray, etc. manually, similar to what was in the settings. I tried changing this to the full path (/home/johan/dvdrip/...). Then it worked!

However ....

I popped in a dvd and started a copy to iso. For a moment, the "XBMC busy" appeared in the lower right hand corner, then nothing. I was back at the "Programs" prompt in XBMC. So I clicked on "Swiss Army Knife" again. This time XBMC crashed to desktop.

linuxluemmel Wrote:Activate debug-log and use a pastebin that we can have a look on it ..

See http://pastebin.com/CLbCpPrS
It was my guess that nobody is using a other shell than bash ....
OK I change this ... all shell-scripts do exit if the shell is not bash.
Did you enable verbose debug as well for xbmc ?
Are you using the offical Beta 1 ?
In the moment I prepare the menu-system for the transcode-screen

I will try to transcode to the folllowing formats

- DVD -> mpeg2
- DVD -> XVID (Huh is this format still usefull ??)
- DVD -> ISO
- DVD -> H264 (Handbrake low-profile -> the same settings like in my old script)

I have 2 formats in mind that may usefull but I do create them If the users would need them.

- Transcode DVD to a optimized value for Iphone
- Transcode DVD to SONY PSP

Regards
Hans
linuxluemmel Wrote:Yes ,-)
Copy your xbmc.log to a pastebin and may also your settings.
Can you execute the command xbmc@localhost without any password ?
There is a test command inside the expert-mode.

Her is the debug log
http://pastie.org/1155421

My settings are:

Script devices:
/dev/sr0

Used dirs:

/dvdrip/*

Codec: Divx

Rest default and all "enable" turned off except verbose debug.

ssh works fine
Your pastebin is to short :-)
Use a other with more space

The setting divx has no effect until now.

Please try to run the shell-commands in a terminal.

http://code.google.com/p/swiss-army-knif...LinuxShell
Sorry thought it was enough.

Some more pastie:

http://pastie.org/1155588

changed to h264 now.

Output of the script xbmc wants to run (dvd0) is:
Code:
xbmc@xbmc:~$ sudo bash .xbmc/addons/script.video.swiss.army.knife/shell-linux/dvd0.sh

----------------------------------------------------------------------------
script    : dvd0.sh
cat: version: No such file or directory
copyright : (C) <2010>  <[email protected]>
changed to /home/xbmc/.xbmc/addons/script.video.swiss.army.knife/shell-linux
----------------------------------------------------------------------------

----------------------- script rc=0 -----------------------------
-----------------------------------------------------------------
cat: version: No such file or directory
please do run the script without sudo
change to script directory :
/home/xbmc/.xbmc/addons/script.video.swiss.army.knife/shell-linux

and execute ./state.sh /dev/sr0

The output of state.sh should look like here :

Code:
user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$ ./state.sh /dev/sr0

---------------------------------------------------------------------
script    : state.sh
version   : 0.6.11 [swiss-army-knife addon]
copyright : (C) <2010>  <[email protected]>
changed to /home/user/.xbmc/addons/script.video.swiss.army.knife/shell-linux
---------------------------------------------------------------------

INFO [media:[DVD-ROM]]

----------------------- script rc=0 -----------------------------
-----------------------------------------------------------------
user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$

If you don't have this output ... (may BLUREAY instead of DVD-ROM) then
we should have a closer look to your system.

If the state.sh script do not report BLURAY or DVD all the rest is not working ...

Please pastebin the FULL log of xbmc.log .-)
linuxluemmel Wrote:cat: version: No such file or directory
please do run the script without sudo
change to script directory :
/home/xbmc/.xbmc/addons/script.video.swiss.army.knife/shell-linux

and execute ./state.sh /dev/sr0

The output of state.sh should look like here :

Code:
user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$ ./state.sh /dev/sr0

---------------------------------------------------------------------
script    : state.sh
version   : 0.6.11 [swiss-army-knife addon]
copyright : (C) <2010>  <[email protected]>
changed to /home/user/.xbmc/addons/script.video.swiss.army.knife/shell-linux
---------------------------------------------------------------------

INFO [media:[DVD-ROM]]

----------------------- script rc=0 -----------------------------
-----------------------------------------------------------------
user@xbmcdev:~/.xbmc/addons/script.video.swiss.army.knife/shell-linux$

If you don't have this output ... (may BLUREAY instead of DVD-ROM) then
we should have a closer look to your system.

If the state.sh script do not report BLURAY or DVD all the rest is not working ...

Please pastebin the FULL log of xbmc.log .-)

The state Script gave me the expected output.

And finally the full log

http://pastie.org/1155741

Running dvd-handbrake seems to work as well (not finished yet)
linuxluemmel Wrote:It was my guess that nobody is using a other shell than bash ....
OK I change this ... all shell-scripts do exit if the shell is not bash.
Did you enable verbose debug as well for xbmc ?
Are you using the offical Beta 1 ?

Not having Bash wasn't a conscious choice: apparently it's not the default when you run XUbuntu...

Yes, I am running Beta1, latest svn installed from launchpad team-xbmc-svn.

New log, including xbmc debug is on: http://pastebin.com/Ac0H9vBz.

Hope you'll be able to figure this out ...
flobbes Wrote:And finally the full log
http://pastie.org/1155741
Running dvd-handbrake seems to work as well (not finished yet)

Your log looks fine but I do not see why the dvd-rip is not started ....
JohanE Wrote:Not having Bash wasn't a conscious choice: apparently it's not the default when you run XUbuntu...

Yes, I am running Beta1, latest svn installed from launchpad team-xbmc-svn.

New log, including xbmc debug is on: http://pastebin.com/Ac0H9vBz.

Hope you'll be able to figure this out ...

Please try try to run shell-commands direct .....
You can find a overview of all shell-commands inside the wiki-pages
of the project.
Ok I figured out a problem.

2 Of the logfiles were owned by root and the script therefor couldn't write/append to them.

Thanks for your help!
No problem ;-) you 're welcome
I added a lot of more verbose messages to log inside release 0.6.15
Cu and greetings from switzerland
Hans
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44