Kodi Community Forum

Full Version: Playing unfinished multi-part RAR and ZIP sets?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In older versions you used to be able to begin watching avi's out of multi-part rars and zips once you had the first one (.r01) and as long as it had the later parts when it needed them it kept playing, or just stopped if it couldn't find that one. So essentially if you were copying files starting with r01 you could immediately begin watching.

Now XBMC just starts then immediately stops the file before it has a chance to play. I haven't yet figured out which version the functionality is removed, but I am looking into it. What steps should I take?
DVDPlayer never supported this since ffmpeg doesn't support a "noseek" flag. Only using mplayer on Xbox did this ever work, not that it's particularly useful. Without logs, your platform, details in general, etc, there's nothing anyone can do to help you.
I posted an example debug log onto pastebin -> http://pastebin.com/f1a25883b This paste comes from a laptop running Atlantis 8.10 on Windows 7, though the same result on any other windows platform running any other xbmc version.

You are probably right that the last time this worked was on an xbox because I cant seem to start the movies even with the earliest windows betas.

So I guess that leaves me with a couple questions:
1. Is there any way to accomplish this without a '-noseek' flag?
2. Is there any way to run a video in xbmc with mplayer (i remember you used to be able to choose the player on the xbox)

Thankyou for your time/responses.

p.s. while you may not find this a 'useful' feature, it certainly is to me, being able to pseudo-stream videos from usenet instead of waiting for a download is timesaving.
You'd have to use the external player stuff, but normal mplayer won't play out of RARs I don't believe.