Kodi Community Forum

Full Version: big lag when entering Library if SMB source is unavailable
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm getting about 50s screen hung when entering TVShows library if I have my NAS offline (also navigation is horrible). Making usability of Library pretty much to nothing.

It seems to me, that XBMC tries to access those tv shows on smb shares which haven't got episode thumbs from thetvdb scraper. But I generated all those thumbs automatically accessing all episodes prior to this!


How can I prevent this happening? SadSad I don't really want XBMC unnecessary accessing smb sources even if they're available, unless it's ofc required for actual media playback.

Thanks for any help.

XBMC Live, SVN 21866

Code:
07:19:27 T:3046000528 M:3063582720   DEBUG: OpenDir - Using authentication url smb://test:[email protected]/SERiES/Beyond%20Belief%20Fact%20Or%20Fiction
07:19:28 T:3046000528 M:3063590912   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://test:[email protected]/SERiES/Beyond%20Belief%20Fact%20Or%20Fiction'
                                            unix_err:'6e' error : 'Connection timed out'
07:19:28 T:3046000528 M:3063590912   ERROR: GetDirectory - Error getting smb://NAS-111/SERiES/Beyond Belief Fact Or Fiction/
07:19:32 T:3046000528 M:3063566336   DEBUG: OpenDir - Using authentication url smb://test:[email protected]/SERiES/Pasadena
07:19:33 T:3046000528 M:3063566336   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://test:[email protected]/SERiES/Pasadena'
                                            unix_err:'6e' error : 'Connection timed out'
07:19:33 T:3046000528 M:3063566336   ERROR: GetDirectory - Error getting smb://NAS-111/SERiES/Pasadena/
...
07:20:35 T:2934954896 M:3050110976   ERROR: Unable to find host: NAS-111
07:20:35 T:2934954896 M:3050110976   DEBUG: ExtractThumb - trying to extract thumb from video file smb://NAS-111/SERiES/Beyond Belief Fact Or Fiction/
07:20:37 T:2926562192 M:3050119168   DEBUG: OpenDir - Using authentication url smb://test:[email protected]/SERiES/It%27s%20All%20Relative
07:20:39 T:2926562192 M:3050127360   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://test:[email protected]/SERiES/It%27s%20All%20Relative'
                                            unix_err:'6e' error : 'Connection timed out'
07:20:39 T:2926562192 M:3050127360   ERROR: GetDirectory - Error getting smb://NAS-111/SERiES/It's All Relative/
07:20:39 T:2926562192 M:3050127360   DEBUG: Thread 2926562192 terminating
07:20:42 T:2934954896 M:3050143744   DEBUG: CFileSMB::Open - opened SERiES/Beyond Belief Fact Or Fiction/, fd=-1
07:20:42 T:2934954896 M:3050143744    INFO: FileSmb->Open: Unable to open file : 'smb://test:[email protected]/SERiES/Beyond%20Belief%20Fact%20Or%20Fiction'
                                            unix_err:'0' error : 'Success'

full debug log:
http://pastebin.com/m53856605
tried to disable automatic creation of thumbs, look for remote share, neither did help.

Basically if I have 1 smb source unavailable it makes a navigation in library really painful process. It doesn't matter if thumbs were scraped or not, but initial library enter definitely has something to do with thumbs, if I enter TV show which got episode thumbs extracted from video I don't see any of them, after a while they will randomly appear from local cache, still xbmc tries to reach source first...

I can post more debug logs, if anyone want to look into it.
It's not just trying to fetch the thumbs.. at least I don't think so.

Please provide a log where you have disabled the option to generate thumbs for those that don't exist. Also, you mentioned you already generated the thumbs... how did you do that?

Thanks.
I generated thumbs when source was online by accessing all seasons of all my tv shows. They worked fine when source was online.

Full debug log with automatically generate thumbs disabled here:
http://pastebin.com/m508a55db

In this one I also entered one show as an example of what I described above.
thumb crcs won't match, i edited my nas path little bit for obvious reasons! but they appear all ok after while (source still offline)

Also worth mentioning is that my second NAS is being accessed when entering library, this one is online, but sometime at standby and unneccesary requests like this one wakes it up.

19:24:53 T:3045676944 M:3060903936 DEBUG: OpenDir - Using authentication url smb://test:[email protected]/DATA/SERiES/SD/I%20Claudius
It's hard to say what the call is that is going to your NAS at this time (and the reason for it).

If you can debug this and add a breakpoint to see where this is trying to call OpenDir, that would help tremendously.
What do you mean by adding a breakpoint? Care to explain that little bit to me? Thanks!
I've tried "Mount SMB shares" in Network settings, but I think it doesn't work. I have smbfs installed made sudo changes, but I don't see any mounted points, where are they supposed to be mounted? Is this option valid?