Kodi Community Forum

Full Version: Adjust refresh rate Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i am trying for 2 weeks now to get automatic adjust refreshrate working correctly Rofl

defined modelines for 23.976,24p,50p,60p in xorg.conf.

automatic adjustment for 25hz,30hz works perfectly and even
[email protected] is working very smoth Big Grin no problem here..

but when i want to play a mkv with exactly 24.000hz xbmc allways switches mode to 23.976hz modeline resolution...xbmc never touches the 24p modeline

any idea or tips are welcome Wink

i am using zotac ion A with xbmc live installed, updated to xbmc pre-9.10r22097...

xbmc.log
Xorg.0.log

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Wed May 27 03:15:36 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       14.0 - 70.0
    VertRefresh     24.0 - 62.0
    Option         "DPMS"
    Modeline    "[email protected]"  74.230 1920 2560 2604 2752 1080 1084 1089 1125 +hsync +vsync
    Modeline    "[email protected]"      60.28 1920 1952 2176 2208 1080 1105 1110 1135 +hsync +vsync
    Modeline    "[email protected]"     148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    Modeline    "[email protected]"  74.176 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync Interlace
    Modeline    "[email protected]"  148.352 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync
    Modeline    "[email protected]"     74.25 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync Interlace
    Modeline    "[email protected]"     148.500 1920 2008 2056 2200 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "DynamicTwinView"      "False"
    Option         "ExactModeTimingsDVI"  "True"
    Option         "UseEDIDFreqs"         "False"
    Option         "ModeValidation"       "NoEdidModes, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"
#    Option         "ModeValidation"       "DFP-0: NoVesaModes, NoXServerModes, NoPredefinedModes"
#    Option         "ModeValidation"       "AllowNon60HzDFPModes, NoEdidModes, NoEdidDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck,NoMaxSizeCheck,NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck"
    Option         "HWCursor"             "Off"

    SubSection     "Display"
        Depth       24
        Modes      "[email protected]" "[email protected]"  "[email protected]" "[email protected]" "[email protected]" "[email protected]" "[email protected]"
    EndSubSection
EndSection

Section "Extensions"
  Option      "Composite"           "Disable"
EndSection
that's because xbmc (xrandr) detect refreshrates from edid even if you have it disabled in xorg.conf (edid usually has only one frequency for 1080p24)
unfortunately you can't define own custom resolutions afaik