Kodi Community Forum

Full Version: Changed skin - screen is now blank. Help!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So everything was going swimmingly until I installed Aeon. After switching to Aeon and all the fonts were missing (I know why now and adding the fonts hasn't helped) I rebooted - only to be launched into a black screen after the XBMC boot process finishes.

Is there any way I can go in via ssh and change it back to a working skin?

I really don't feel like going through the whole setup process again! Big Grin

Thanks for any help.
I had the same problem with fonts. Are you sure you unpacked the zip to correc location? I had to move the font directory one lvel up from the initial placement.

Otherwise I would imagine that it will revert to default if you delete guisettings.xml
Yeah, I'd moved the fonts one level up.

Thanks for the tip on deleting guisettings - unfortunately, that didn't work and I've obviously made more errors than just that.

I've posted an error log here, if anyone can possibly see what's going on:

http://pastebin.com/m4d95108a
Quote:ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
07:52:55 T:3041138576 M:3077828608 ERROR: Unable to save settings to special://masterprofile/guisettings.xml
07:52:55 T:3041138576 M:3077828608 INFO: Resetting settings
07:52:55 T:3041138576 M:3077828608 ERROR: Delete - Error deleting file /home/xbmc/.xbmc/userdata/guisettings.xml
07:52:55 T:3041138576 M:3077828608 ERROR: Delete - Error deleting file special://masterprofile/guisettings.xml
07:52:55 T:3041138576 M:3077828608 ERROR: Unable to save settings to special://masterprofile/guisettings.xml

So it tries to create a new guisettings.xml but it can't. Check for file permission problems; the user running xbmc should be able to write everywhere in the xbmc tree (well, at least in the userdata tree).

(masterprofile is mapped to: /home/xbmc/.xbmc/userdata, check the permissions)