Kodi Community Forum

Full Version: [LINUX] XBMC crashes while playing MTS files (w/VDPAU); Worked fine previously...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Up until recently I was using Ubuntu 8.04 with an older SVN version of XBMC and it played my MTS files with VDPAU just fine.

However, now I'm using Ubuntu 9.10 and XBMC (r22278) and when I try to play an MTS file using VDPAU then XBMC immediately crashes.

Here is my debug log: http://pastebin.com/m20d85aad

The videos play fine in software mode but my CPU isn't powerful enough to decode them (they are [email protected] 24 Mbps).

I'm also using nVidia driver 185.18.

Furthermore, I've tried XBMC Live 9.04.1 (which uses nVidia v184, I think?) and when I select VDPAU + MTS files I just get a black screen or a mostly black screen with garbage displayed.

All other video works fine with VDPAU (H.264, etc).

I'm confused because this worked fine on my previous setup with an older version of Ubuntu, XBMC, and probably an older nVidia driver. Sad

Can anybody help me out?
Please read stickies on how to post in a useful manner.

If XBMC is crashing, we need backtrace.
Sorry.

It turned out to be that my BIOS was set to only 64 MB of VRAM. Once I changed it to 512 MB it started working fine.

Hopefully this helps somebody in the future.

Sorry for the post. Sad