Kodi Community Forum

Full Version: No subtitles on Ubuntu system with NVIDIA GeForce 8600 GTS/PcVSSE2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,

I'm new here so if I do things wrong then please forgive me. I have installed XBMC on my system:

Kernelversion: 2.6.28-15-generic
Processor: Intel® Pentium® D CPU 3.20GHz
Memory: 4 GB
Video: NVIDIA GeForce 8600 GTS/PcVSSE2
Resolution: 720x480 480P 16:9 59.94 H
OpenGL version: 3.0
HD: 1x 80 GB and 1x 500 GB

On my system I hooked up a old television(Wide screen - Diagonal 70cm) with a s-video cable.

I installed the latest NVIDIA drivers from the website and calibrated my xbmc but I can't see any SRT subtitles.

I searched the web and this forum. I already tried the option with same filename but this doesn't work. Already tried the option to use another skin.


I tried to edit my xorg.conf but it won't start my xbmc when I reboot. Here is the output of my running xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Fri Aug 14 17:54:58 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "NoLogo" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


I hope that anybody can help me with this problem. If you need any other information then ask me.
Doesn't anybody know how to fix this problem??
Please provide a little bit more information, specifically a debug log which will tell everyone a bit more about what's going on in the background.

See this thread for further details:

Sticky: [LINUX] HOW-TO post about a problem in a useful manner
Hi Maxim,

Thnx for your reply. I've copy my debug log to the following link:

http://pastebin.ubuntu.com/260872/

In the log I did the following actions:

  1. start xbmc
  2. start a movie
  3. start a subtitle
  4. stopt a movie

Skinname: MediaStream
Videocodec: I don't know where to find that.
Architecture: i686
Kernel: Linxu 2.6.28.15-generic #49 Ubuntu
XBMC revision: R1414

I've you have any further questions please ask me. I want this problem solved.
Your build is quite old. Subtitles have been completely reworked recently. Try to hunt a newer one.
Forgot to edit this post and have writed a new one down here.
althekiller Wrote:Your build is quite old. Subtitles have been completely reworked recently. Try to hunt a newer one.

Thnx for the reply. A friend remeberd me that I have maybe posted the wrong SVN it should be:

XBMC: 9.0.4.1 R20654 (Compiled: May 25 2009)

Is this the right one or is there still a newer one?

I used the following manual:

http://www.xbmc.org/forum/showthread.php?t=38804

Greetz from the Netherlands - Bart

UPDATE!!

The subtitles work with a few films but not with others. I'v got a few movies from my friend. And with a few films there is a *.srt file within that folder. But when I download a movie and copy it to the movie folder en renamed exactly to the movie name but is doesn't work.