Kodi Community Forum

Full Version: Screensaver and Video Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have recently upgraded to Ubuntu 9.04 due to xbmc compiling issues on 8.10. I have the following minor issues:

1) XBMC Screensaver keeps kicking in when watching a movie. If I press a key, then I can continue playback.

2) Ubuntu screensaver also kicks in when a watching a movie as well. I don't think I saw this behaviour on Ubuntu 8.10.

3) When a watching a movie that is 720P, I keep getting a hang after a few seconds of playing if database scan is present. When I stop the database scan, it plays the video fine without any issues.

System Specs:
Ubuntu 9.04 x86
XBMC SVN 22456
Intel ATOM 330 using integrated video card
2GB RAM

Will post debug logs tonight when I get home ..
Did you "upgrade" or do a clean install? You're in for a world of hurt if you did the former. All kinds of stuff won't work for apparently no reason. Your best bet is a clean install.

CrashX Wrote:1) XBMC Screensaver keeps kicking in when watching a movie. If I press a key, then I can continue playback.
Must be the gnome-screensaver, I've seen no other reports of this.
Quote:2) Ubuntu screensaver also kicks in when a watching a movie as well.
Disable it
Quote:I don't think I saw this behaviour on Ubuntu 8.10.
Sure it did.
Quote:3) When a watching a movie that is 720P, I keep getting a hang after a few seconds of playing if database scan is present. When I stop the database scan, it plays the video fine without any issues.
I won't waste time speculating w/o logs.
First of all, thanks for feedback .. Here is my respone to your questions ..

althekiller Wrote:Did you "upgrade" or do a clean install? You're in for a world of hurt if you did the former. All kinds of stuff won't work for apparently no reason. Your best bet is a clean install.

Yup I did a clean build as always.

Quote:Must be the gnome-screensaver, I've seen no other reports of this.

I had disabled it to fix issue 2. I can confirm it is xbmc because when I changed xbmc screensaver timer to 60 minutes .. then it would appear after 60 minutes ..
Is screensaver activity recorded in the debug log?
In Windows, we can use api SystemParametersInfo ( http://msdn.microsoft.com/en-us/library/...spx?ppud=4 ) to disable system screensaver ... Is their similar api for Linux ?
CrashX Wrote:Yup I did a clean build as always.

Sorry, I wasn't clear. I was referring to the ubuntu upgrade, not XBMC. Is that the same one you're talking about?
althekiller Wrote:Sorry, I wasn't clear. I was referring to the ubuntu upgrade, not XBMC. Is that the same one you're talking about?

I choose the ubuntu upgrade option ... I know for a fact in windows you are asking for trouble but never knew linux would be the same ... It went pretty smooth the upgrade and pretty much everything including my webserver was working fine..

I have all my media/webserver on my ubuntu os drive os so I didn't want to do clean install since I have to backup them .. I presume clean install means it will wipe os drive.
Quote:I presume clean install means it will wipe os drive.
I am guessing it will work fine to shrink the / partition, install on remaining space and then manaully clean the former /.
Screensaver issue was due to gnome-power saver mode kicking it .. I disabled it and now it is fine..

XBMC log hanging when playing video and database scan .. http://xbcm.pastebin.com/m3bea1b5c