Kodi Community Forum

Full Version: Asrock Ion 330 - No Surround on SPDIF
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Apologies for posting similar on another thread, however things have changed slightly since then.

So far I have only managed to get sound working on xbmc in stereo. I only get sound on video, and none through xbmc itself (ie. when navigating etc).

When I installed ubuntu I used one of the scripts going around, and noticed today that it actually sets up for hdmi sound. Does this mean I need to remove/reconfigure something for getting multichannel over SPDIF?

Any help would be greatly appreciated, as at this point I'm unsure if I need to be looking at my asoundrc files or something else similar.
First of all have you tried any of the solutions posted in a lot of threads ?

Also see my signature on how to psot a problem in these forums, you will get faster help by doing some work yourself. Hope to get some more info from you.

And welcome to the forum btw ! Smile
Thanks Boxhead.

As you can tell from my post, it's been a bit of a scattered mess. I've tried to go through a lot of the solutions I've found in the threads, but there doesn't appear to be much consistency as they all talk about different things.
Anyhow, I'll take a read on how to post, and will come back with hopefully a more useful post later.
OK here goes....

XBMC Version 9.04.1 r20654
Ubuntu Minimal 9.04
i686 architecture
Install method - installed minimal cd and then used flxfxp script to install/setup xbmc
H/W - Asrock Ion neo 330; connecting via optical out to my amp.

XBMC Audio Settings
I've tried a few but the only ones which seem to make a difference are
output device: iec958

Log file:
http://pastebin.com/m80e6a04

Some other bits which may help:

[email protected]:~$ aplay -L
front:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
Front speakers
surround40:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
HDA NVidia, VT1708S Digital
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)


[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: VT1708S Analog [VT1708S Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
card 0: NVidia [HDA NVidia], device 1: VT1708S Digital [VT1708S Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I'm using the .asoundrc file boxhead has posted elsewhere.


Problem:
I'm only getting audio when playing a video. Not getting any navigation sounds in xbmc. Furthermore the output is only being passed out in stereo.

The initial setup script setup audio for hdmi output so not sure if this has caused the issue.

Apologies if this is real basic, as I'm extremely new to linux!! Any help greatly appreciated because I'm pretty much all out of ideas.
not having navigation sounds was fixed for me by disabling the digital option within xbmc audio options.
since you use optical you cant do that Wink

I only need stereo output so your case is different since you want more.

The only tips i can think of is that you are running a quite old SVN version of XBMC. atleast you should try a SVN version over 22XXX
sudo apt-get update
sudo apt-get upgrade

See the sticky to enable the daily builds PPA repo's to your sources.list if not done.

But i understand anyhow that there is alotta users having problems with multichannel sound in linux/xbmc.
Been reading around for about 20 mins or so...but have yet to find a way to go to a specific build. I have read that r22528 seems to be a decent build, how would I go to this?

Also I saw a guide for updating XBMCLive - Pretty sure this isn't me so are you talking about the sticky?
I'd like to find this guide for updating XBMCLive... who know an update can solve my problems here...
Well I've managed to update to the latest stable SVN, but still nothing.

Surely somebody with an Asrock has come across, and solved this issue before!!
Managed to get menu sounds....I ended up needing to change the device number used in .asoundrc. It was set to use 4 by default I believe, and this was changed to 1.
I had a similar problem. Is alsamixer set up correctly? Then double check both devices are set to iec958.
kees667 Wrote:I had a similar problem. Is alsamixer set up correctly? Then double check both devices are set to iec958.

kees667, do you have a screenshot of how your alsamixer is setup? as i'm not getting sound but am unsure if alsamixer is correctEek
I had the same problem. Needed to umute all 4 iec958 devices in alsamixer and set output device and passthrough device in xbmc to iec958. Also had to restart xmbc for changes to take effect.