Kodi Community Forum

Full Version: Can't get Fanart in Music
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I can't seem to get the Fanarts to display in music folder unless I'm i Library mode. I like to keep the folder structure intact, that's why I don't want to use Library mode.
I have assigned a specific folder with Fanart in Settings > Skinsettings > Backgrounds > Music. All I get is a white Screen, but when I leave the Music folder I can see the Fanart for a fraction of a second. It seems like there is a blank (white) Fanart on top of the Fanart I have assigned.
When I search for Album info, I do NOT have the opportunity to retrieve Fanart. The button marked Get Fanart is Greyed Out. This is also true for Library Mode.
I'm using Build 23120 and my Folder structure is Music/Artist/Album/Track

What can I do, to get that White Sheet off my Fanart?
start by downgrading xbmc to r22528. everythig above is not stable and can result in (partial) white screens in several places.
the 'get fanart' button is only enabled when searching for artist info.
White textures bug fixed at r23145
Same for me, no Fanart in Library mode, only on files mode.....Im running Build 22514
did you perhaps add the fanart after you scanned your music to the library?
if this is the case you'll have to delete the music database and rescan.

xbmc doesn't pick up fanart if you add it afterwards.
.............yes, i add it after the scan :p


please sorry ...sorry sorry ^^


EDIT: After a new install, fanart dont display in Library Mode ...and my fanart were alreay inside my folder
I scanned and rescanned my Music Library, but nothing to do, same problem, no fanart in Library mode.

Just a question,, wich "string" is related to the artist informations in "album.nfo" ?

im putting one of my nfo online , maybe im doing something wrong....

http://pastebin.com/m3722d8

Edit: xbmc's wiki is my friend ^^, i must add "<biography>Artist/Band biography text</biography>" and i think it"ll be ok Wink
Woww... from build 23333 and on it works again. Beautiful fanarts in music to..
I can't seem to get music fanart either. Which scrapper is everyone using. Also when I click on artist information it just asks me type in the name, and when I do it just keeps prompting the same window.
smush420 Wrote:I can't seem to get music fanart either. Which scrapper is everyone using. Also when I click on artist information it just asks me type in the name, and when I do it just keeps prompting the same window.

for fanart it does not matter so much what scaper you're using as all of them will get fanart from the same site (htbackdrop.com)
check if the fanart setting is enabled in Settings > Music > Library > Scraper Settings (if you're using a recent svn version).

chances are of course, there's no fanart available for the artists you're scraping.
you can manually check htbackdrops.com if this is the case.
Thanks Ronnie, I thought that blue meant checked, I switched and now fanart is working, thanks so much.