Kodi Community Forum

Full Version: newbe needs help playing .m2ts/.ts/mkv
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am trying to evaluate XBMC on Ubuntu, playing 1080p .m2ts/.ts/mkv files. I still have not found my way around XBMC so please help me.

Hardware: asus motherboard w/ onboard nvdia chipset that I know works with VDPAU on minimyth playing all the HD formats.

Symptoms: nothing happens when trying to play .m2ts, .ts, .mkv, or even dvdshrinked .iso

.avi plays fine. VLC will play the .mkv fine, but there is something wrong with the auido. XBMC plays the .avi with proper 5.1 decoding in the amp.

I see in the online docs x264, and .mkv are supported, but I get nothing.

I stared from a minimal ubuntu install, and eventually tired using apt-get to update to the latest SVN. I am not sure if this worked ( it appeared to ) but it didn't change the video play problem.

#1 - What version of XBMC do I need to play .m2ts, etc. files
#2 - Any special configuration required?
#3 - How can I install and verify this version in a foolproof way

Please please help I really like this interface
[QUOTE=xb4me;415212
#1 - What version of XBMC do I need to play .m2ts, etc. files
#2 - Any special configuration required?
#3 - How can I install and verify this version in a foolproof way
[/quote]

1. Any
2. Shouldn't need any - should work out of the box.
3. How did you install it.

Best bet is to give us a debug log of you trying to play a file, and it should give us some details of what is going wrong.

See my signature for details on how.
I just know you are going to ding me for snipping the log file, but it is just too big. Hopefully I got the relevant output. If not I have the files saved off, so just ask...

So, at the top:
--------------------------------------------------------------------

http://pastebin.com/mc6259b5

Then when I try to play an iso ( AMERICAN_BEAUTY.ISO ):

http://pastebin.com/m30aa02bf
.mkv output in next post...
-----------------------------------------------------------------

Then when I try and play an .mkv ( bable.mkv )


-----------------------------------------------------------------


http://pastebin.com/m2c46b094

please help
Copy the files locally and retry.
Well the .mkv plays locally! How do I make it play off the network?

The ISO does not play locally, here is the output from playing the ISO locally:

http://pastebin.com/m4d205ce8

please help
I just wanted to report that after a couple of days of bashing my head I went and re-installed the entire OS from ubuntu minimal then used the excellent script:

http://flx.me/xbmscript/

I installed the non svn release and it worked great. All my problems are gone, well sort of. Everything plays, but I am less than satisfied with the video quality. I will post another thread shortly...

My networking problems were related to SMB mounting of the open solaris zfs file system. Don't know why I had a problem, but using nfs instead did the trick.