Kodi Community Forum

Full Version: Music videos not added to library while scanning for content
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I bought a Asrock 330 an installed Ubuntu with XBMC and it all works flawlessy...except for the music videos library.

Ive done the following steps:

1. Added the directory where I store my musicvideos
2. Rightclicked the dir, set the content to Music Videos, choosed MTV as scraper and also activated Run Automated Scan and Scan recursively.
3. Tried to look for it in the library or try partymode but it just doesnt find any music when scanning.

My structure is like this:
Musicvideosfolder\Greatcomposer1-The-Othersong\othersong.mkv or similar to that.

Ive looked all over the forum and cant find any solution for my problem since it works perfect with ordinary movies.

Any suggestions would be really appriciated!
Thanx in advance.
A debug log will likely tell you what's going on.


Im not to good at reading it and understanding though Sad
It doesnt add anything to the library Sad
Post the entire log, no snippets please.

Okey here it is! (new clean install may be slight different, same problem though)
Try to update to a more recent SVN version of XBMC and report back if the issue still exists.
Same error with new svn Sad
There's no real scan going on as it was skipped due to no changes. Please re-scrape manually and pastebin the log of that session.
Okey sorry, here is a new link where I added the source and scanned it:

Ive also noticed that I dont get any sound from my mvids, get sound from movies though, started a mvid and stopped it and included it in the log aswell if there some common error perhaps you can see.

Big thanx in advance for trying to help me!
In order to solve your scraping problems you should remove the .nfo files. I am quite sure it's related to it.
Please pastebin the .nfo file so we can check what exactly is wrong.

Regarding those VDPAU erros in the log.. any chance you have enabled some upscaling options in video settings?
I removed all the nfo files from my 3 folders so theres only a .mkv mvid in each dir now. Still the same problem Sad

Heres a new xbmc.log after booting the system with the nfos removed and all previously added stuff to the library removed and my attempt to add the mvid dir and scan it.
It still doesnt get any sound though, but the movies does Blush

Heres the new log: http://pastebin.com/d213b520a

I used this install for my xbmc: http://forum.xbmc.org/showthread.php?tid=55282 wich is custommade for my Asrock 330, the only setting I did was to change to VDPAU as Render Method and enable Adjust refreashrate.
Got sound working now by changing both devices under audio hw to iec958... Still the problem that it wont put musicvideos in the library though Sad
Search terms passed to the scraper are invalid or there's just no result for it. Mind posting a trac ticket for this issue so we don't forget about it? Thanks.
Thanx for your help vdrfan, ticket posted.