Kodi Community Forum

Full Version: XBMC crashes from suspend: lirc_dev: lirc_register_plugin: minor (0) just registered!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Since I connected a MCE IR receiver xbmc crashes when trying to resume from Suspend.
Doesn't matter if I use the remote, keyboard or hardware powerbutton to resume. XBMC Crashes with all when the IR receiver is connected.
THe XBMC fault is like this:

lirc_dev: lirc_register_plugin: minor (0) just registered!
PANIC: double fault, gtd at c1c28000 [255 bytes]
double fault, tss at c1c2e280
eip = f7c449c6, esp = 0000ef38
eax = f7c48c08, ebx =fffffe00, ecx = 0000ef50, edx = f7c48ba0
esi = f7c48ba0, edi = bfc0c904

The system hangs completely and cannot be ssh'ed anymore. Cold boot is the only thing that works.

System: Asrock ION 330
IR receiver: HP OVU400102 (dozens found on Ebay)
XBMC: Live CD updated to 9.04.2 with latest NVidea drivers installed on HD

The remote works fine, except for resuming.
When I completely disconnect the IR receiver, resuming by pressing the keyboard works fine again.

I already put back a non-edited remote.xml in system/keymaps, use another USB port but nothing helps.
Sorry I cant help.
Just wanted to say I have the exact same problem. Same hardware as you as well.
I too have the same issue on my Revo 330. I can resume ok when pressing a key on the keyboard but although the remote does wake it up, it crashes with the above error.

Remote is a HP MCE

Image

Image
I use the same remote as you Birty.
Has any one of you solved the problem yet?
Sorry for the late reply but no, I haven't resolved it unfortunately.

I don't even know if it is at all possible to successfully resume with any remote let alone our HP remotes.

I've kinda just 'put up with it' for the meantime. Sad
Same Problem here Sad Anyone can help?
Good news and bad...

I upgraded to 9.11 Alpha2 r24548 (Nov 12 2009) and I am now able to resume from standby without the above error. Laugh

However, after it has resumed the remote does not work. Sad
Hi, I have similar problems with my remote but already at system-startup. Only solution was to disable lircd (the daemon that connects to the IR-receiver) because this was crashing and totaly squishing the system. I guess it is somehow related to udev. Might be a result of some of the changes between jaunty and karmic.
Any update?`When i resume from supend i only get a black screen Sad even with beta 1
anyone get this remote working on resume?

tried this guide but no luck

http://wiki.xbmc.org/?title=Automatic_li...ume_script


also is anyone elses remote very jumpy, like for example you press back button and some times it will jump back 2 pages

Have tried window mce remote new and old option in lirc and this happens with both

Its not the remote itself, as it happens with a microsoft mce remote i have from another pc aswell (when using mircrosoft remote with the hp ir receiver)
This was the case for me with XBOX playack kit too with 9.04
And now on 9.11. I too lose remote after resume, but if i reboot all goes back to normal..
Tried the above script with Xbox Playback kit installed.. Same issue..
Will not work from resume. .
anyone get this remote and receiver to work ok with resume?
Finally some good news and more importantly no bad news!!

I've been able to get the above HP MCE remote to suspend and resume XBMC on my Revo 3610. For various reasons I decided to do a fresh Live HDD install with 9.11-rc1. Once it was installed I found the remote worked fine in XBMC and although I could send the Revo to suspend, I couldn't wake it with the remote like I could previously. So then I had a look around and found this. Had I found this (I clearly wasn't looking hard enough...) before the reinstall I would have tried it so it's worth trying it as you are - it may just work.

When I ran
Code:
cat /proc/acpi/wakeup
I saw all devices were set to disabled so as per the instructions I ran
Code:
echo USB0 > /proc/acpi/wakeup
and then confirmed USB0 was set to enabled. I then ran
Code:
nano /proc/acpi/wakeup
and just like in the instructions added:
Code:
echo USB0>/proc/acpi/wakeup
echo "rc.local has completed sucessfully." >> /tmp/resume.log

Finally I did a sudo reboot and then it all worked!

For info I have my IR receiver plugged in to the top right USB port as you look at the back of it. I'm not sure if that matters but thought I'd mention it anyway.

Also my /etc/rc.local file looks like this:

Code:
[email protected]:~$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
SMB0      S4     disabled  pci:0000:00:03.2
USB0      S3     enabled   pci:0000:00:04.0
USB2      S3     disabled  pci:0000:00:04.1
NMAC      S5     disabled  pci:0000:00:0a.0
PBB0      S4     disabled  pci:0000:00:09.0
HDAC      S4     disabled  pci:0000:00:08.0
XVR0      S4     disabled  pci:0000:00:0c.0
XVR1      S4     disabled
P0P5      S4     disabled
P0P6      S4     disabled  pci:0000:00:15.0
P0P7      S4     disabled  pci:0000:00:16.0
P0P8      S4     disabled  pci:0000:00:17.0
P0P9      S4     disabled  pci:0000:00:18.0
[email protected]:~$

and my lspci looks like this:

Code:
[email protected]:~$ lspci
00:00.0 Host bridge: nVidia Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: nVidia Corporation MCP79 LPC Bridge (rev b2)
00:03.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: nVidia Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: nVidia Corporation MCP79 Co-processor (rev b1)
00:04.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: nVidia Corporation MCP79 PCI Bridge (rev b1)
00:0a.0 Ethernet controller: nVidia Corporation MCP79 Ethernet (rev b1)
00:0b.0 IDE interface: nVidia Corporation MCP79 SATA Controller (rev b1)
00:0c.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:17.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:18.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: nVidia Corporation ION VGA (rev b1)
05:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
[email protected]:~$