Kodi Community Forum

Full Version: New Touchscreen mouse issue in SVN 2326-jaunty1
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Sorry mistake in Thread title it should read 23626 !!!

Hi All,

Just upgraded to xbmc-9.04.3+svn23626-jaunty1 and having strange issue in full screen mode with the mouse pointer. I have done a search in the forums and in google and can't see any reports...

system: Ubuntu Jaunty 9.04 all updated to 14/10/2009 (i386)
XBMC: xbmc-9.04.3+svn23626-jaunty1 via PPA
Skin: Default PM3 (ie. I haven't changed anything).
Touchscreen driver: eagalax (also tried evotouch and same results) via USB
Xorg: 1.6 (no physical mouse attached)


I was previously running SVN 22278 and all was fine (I had problems with the Library so I thought I would upgrade, Library was always disabled and had no scan option in context menu for music).

After upgrading to 23626 when I run full screen (xbmc -fs) the home screen loads fine and fits the screen fine at 1152x864 60 Hz (like X windows is configured for) but the mouse behaves incorrectly (I say mouse, but I mean the mouse pointer via touchscreen). The only way I can describe it is it ias if the mouse canvas is a lot larger than the screen, as in the top left corner I can see the mouse, but a 1 cm drag down and it speeds off downwards and off the screen. Same with left to right, one small movement and it shoots off the righ hand side of the screen.

I have no problem in window mode, only full screen. X org works fine in same resolution. Tried the video calibration in XBMC and I can see both corners in the correct area of the screen. I have tried changing the resolution in xbmc... same result.

I picked an older SVN to try and the same issue exists in 23164, so I am now back on 22278 and all is well again (except I have the library issue back).

Any ideas ?? I have had a look in the log file, and I see no obvious errors...

Thanks in advance for any help...

Also just tested:


Which also works...

So a change from 22528 -> 23626 broke my touchscreen..

Any ideas anyone ??


Hi All,

I appreciate that noone else may have this particular issue, but I cannot get around it and have been searching the net for weeks now trying to get passed this issue...

I now have it down to the changes made to the Linux SVN

22528 works fine
23060 doesn't work (ie. the mouse issue as described above)...

Could anyone please comment if any of the changes between these two versions modified the code around display/mouse behaviour as it may help me to identify the issue... I have tried to trace the changes myself, but I don't have a deep enough understanding to really pinpoint anything...

Thanks in advance !!


Next week I should have time enough to try to install last xbmc liveCD on my hardware.
I will let you know if it works or not

Hello, same behaviour. The last version that works for my is 22485.

I try a new clean installation (Ubuntu 9.10 & xbmc 9.11~alpha2-karmic1), and touchscreen in xbmc don't work fine.

The driver used is xserver-xorg-input-evtouch 0.8.8-0ubuntu6 and in normal desktop works fine.
Hey antoni.ros

I still have the same problem, and am unable to get around it.... Oo

But if more people are experiencing it then maybe it will catch someones attention..... I keep trying the latest SVNS every now and again to see if they work....

If I find anything out, I will of course post here...



I applied the patch "fit_to_screen" from post http://forum.xbmc.org/showthread.php?tid...een&page=5. The display seems to be now a full screen window. The touchscreen pointer works with jaunty.

BTW, which skin is recommended for touchscreens? I would favour confluence?


Digby Dude, have you fixed the problem?

Kind Regards
I am still stuck on xbmc_9.04.3+svn22528-jaunty2_i386....

I see you (Spider) have looked into the patch to try and run in it window'd mode but full screen... how did that go...

I have seen several posts of people complaining about the same issue, but no real solution... I find it odd Huh?

I am happy to try things out and/or work with anyone to get this fixed...