Kodi Community Forum

Full Version: hebrew translation
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I started using this skin and I have to say its great!
Only problem is I use a hebrew GUI - I can see the menus just fine but there are specific places where I see symbols and not letters:
1. when I put the scroller on my videos, the "new:" in the other side of the screen is in symbols.
2. when watching information while watching a movie, one line is always in symbols.

I guess it has something to do with the fonts. most of the font in the menus is Arial but in some places the fonts are different.
orduek Wrote:Hi,
I started using this skin and I have to say its great!
Only problem is I use a hebrew GUI - I can see the menus just fine but there are specific places where I see symbols and not letters:
1. when I put the scroller on my videos, the "new:" in the other side of the screen is in symbols.
2. when watching information while watching a movie, one line is always in symbols.

I guess it has something to do with the fonts. most of the font in the menus is Arial but in some places the fonts are different.

if you've selected the arial font, it should use it in all places.
i can't reproduce your problem, if i select hebrew the 'new' label shows just fine.
Image

what version of xbmc are you using? what platform?
are there any errors in the logfile if you enable debug logging?
I use the latest SVN version with Mythbuntu Intrepid (8.10).
It might be related to the OS then.
The font is set to Arial. but I think it has something to do with unicode or something.
I'll check the debuging although I don't think its that kind of bug.
orduek Wrote:I use the latest SVN version with Mythbuntu Intrepid (8.10).
It might be related to the OS then.
The font is set to Arial. but I think it has something to do with unicode or something.
I'll check the debuging although I don't think its that kind of bug.

i'm using Ubuntu 9.04 & 9.10, so we're both on linux.

orduek Wrote:2. when watching information while watching a movie, one line is always in symbols.
does this also happen in other skins?
if not, could you post a screenshot of this?
It didn't happen in other skin because I think those option weren't enabled.
http://picasaweb.google.com/lh/photo/9Q5...directlink

and another:
http://picasaweb.google.com/lh/photo/RyI...directlink
it's indeed weird. both corrupted strings are from the hebrew Transparency! translation file.

could you check if ~/.xbmc/skin/Transparency!/language/Hebrew/strings.xml is ok ?
maybe the file is corrupt? at least check strings 31400 and 31050 in that file.

how about the Settings > Skin Settings page? is that one looking ok?
The xml file looks fine.
Ofcourse it happens in other places, mainly in the settings-->skin setting where almost everything there is in sings.
i think i know what may be the problem...i've been using some incorrect encoding strings in the language file in v2.00. i've fixed it in the full download of v2.01, but not in the v2.00 to v2.01 update package.

check the first line of strings.xml, it should be:
<?xml version="1.0" encoding="utf-8" standalone="yes"?>

if it still says ''ISO-8859-1" on your end, just replace it with "utf-8" and restart xbmc.

let me know if this was the case. ;-)
Great, it worked.
funny thing, yesterday i tried doing that but i wrote UTF-8 instead of utf-8Laugh
thank you.
keep up the great work your doing!
cool, no problem.

if you ever have a few minutes to spare and wouldn't mind helping out,
the Hebrew translation of Transparency still needs a bit of work.
only a part of the skin has been translated so far.
ronie Wrote:cool, no problem.

if you ever have a few minutes to spare and wouldn't mind helping out,
the Hebrew translation of Transparency still needs a bit of work.
only a part of the skin has been translated so far.

I saw it, I'm working on that (slowly but surely).
I changed a few more today.
orduek Wrote:I saw it, I'm working on that (slowly but surely).
I changed a few more today.

great thanx!!
no hurry, of course. ;-)