Kodi Community Forum

Full Version: Instead of suspend, XBMC immediately "restarts"
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi!

I'm using FLXFXP's script and a Ubuntu Jaunty Minimal Install and the ZOTAC ION ITX-A.

Every time I'm pressing "suspend" in the shutdownmenu, the screen get's black and a few seconds later XBMC is up and running again.

It happens on various Versions of XBMC.

Pastebin XBMC.log: http://pastebin.ca/1625467
Pastebin XBMC.log.old: http://pastebin.ca/1625490

Are there any things, I have to configure/install in Ubuntu?

/boot/grub/menu.lst:
title Ubuntu 9.04, kernel 2.6.28-15-generic
uuid 0965a438-e938-43ef-af11-efb3f3ebaa7e
kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=0965a438-e938-43ef-af11-efb3f3ebaa7e ro quiet splash usbcore.autosuspend=-1
initrd /boot/initrd.img-2.6.28-15-generic


It would be great if anyone could help me... Sad
It'll be the Nvidia 190.36 driver, I expect.

Any version after 190.18.03 gives me the same suspend fail issue.

Uninstall your current drivers (with aptitude, or your preferred PPA management tool) then grab the superceded 190.18.03 set from https://launchpad.net/~nvidia-vdpau/+arc...ld/1146840 and manually install them with dpkg

e.g. :
Code:
dpkg -i nvidia-190-kernel-source_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-libvdpau_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-libvdpau-dev_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-modaliases_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-glx-190_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-glx-190-dev_190.18.03-0ubuntu1~ppa1_i386.deb
Yes, same thing with me.

It is the nvidia driver.

If not, than you are not able to suspend in pulicy kit.
Yeah, the drivers are to blame.

I've reinstalled everything, but have taken older drivers and everything works perfect.

The only problem ist, that I can't re-woke the system with my remote (Xbox1-Remote, Xbox1-Receiver). But I think I have seen some possible solutions in the forum. I guess I will try them. Smile
Search for usbcore.autosuspend and play with enabling ports via acpitool to enable the wakeup via remote key presses.
vdrfan Wrote:Search for usbcore.autosuspend and play with enabling ports via acpitool to enable the wakeup via remote key presses.

Danke for pointing the right direction. Big Grin
Bittschön. You're welcome Wink
'kay.

Now, I can wake it up again, but after the re-woke the remote isn't responding anymore. :/

*searching*
Immediat re-woke was gone. Suddenly it started again but I haven't changed anything...?
Have a read thru this thread post 23 is what I did to finally get everything working.
I had the same issue and had tried all the tweaks posted to no avail. After a bit of googling I saw others posting issues with the ehci driver and suspend when usb wakeup is enabled. Posted details on my blog, but the short version is that I had to disable wakeup via /proc/acpi/wakeup for all the USB devices listed except the one my remote was attached to. Didn't have to mess with the usb autosuspend or do anything special with the nvidia driver (190.42).

Big thanks to the devs for the lirc stop/start mechanism! When I was using mythtv I always had to restart myth to have a working remote after resume which meant a 5-10 second delay. With XBMC, I now have a resume time of maybe a whole second and life is good. Smile
Hello everyone!

Since 2009-11-07 (Posting #9) I'm searching for an solution to my problem.

I've done various installs with 9.04/9.10/full/minimal/Live and FINALLY almost every problem is gone.

First Suspend√
Remote is still working after Resume√
Second/Third/... resume is working√

My remaining problem is, that my Xbox1-Remote-and-Dongle can't re-wake my system.

Code:
[b][email protected]:~# cat /proc/acpi/wakeup[/b]

Device    S-state    Status   Sysfs node
PS2K      S4     disabled  pnp:00:09
SMB0      S4     disabled  pci:0000:00:03.2
USB0      S4     enabled   pci:0000:00:04.0
USB2      S4     disabled  pci:0000:00:04.1
US15      S4     disabled  pci:0000:00:06.0
US12      S4     disabled  pci:0000:00:06.1
NMAC      S5     disabled  pci:0000:00:0a.0
PBB0      S4     disabled  pci:0000:00:09.0
HDAC      S4     disabled  pci:0000:00:08.0
XVR0      S4     disabled  pci:0000:00:0c.0
XVR1      S4     disabled  
P0P5      S4     disabled  
P0P6      S4     disabled  pci:0000:00:15.0
P0P7      S4     disabled  pci:0000:00:16.0
P0P8      S4     disabled  pci:0000:00:17.0
P0P9      S4     disabled  pci:0000:00:18.0
PWRB      S4    *enabled

Code:
[b][email protected]:~# lsusb[/b]

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 045e:0284 Microsoft Corp. Xbox DVD Playback Kit
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0000:0000  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

/etc/rc.local
Code:
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
echo USB0>/proc/acpi/wakeup
#echo USB2>/proc/acpi/wakeup
#echo US15>/proc/acpi/wakeup
#echo US12>/proc/acpi/wakeup
echo "rc.local has completed sucessfully." >> /tmp/resume.log
exit 0

Is there anyone who could help me? Sad
OMG! OMG! OMG! OMG! OMG! OMG! OMG! OMG! Image

I did it! After spending billion over zillions of hours I finally did it. Even if I haven't the slightest clue which of the quindezillion tweaks my problem solved I'm so happy.
kurai Wrote:It'll be the Nvidia 190.36 driver, I expect.

Any version after 190.18.03 gives me the same suspend fail issue.

Uninstall your current drivers (with aptitude, or your preferred PPA management tool) then grab the superceded 190.18.03 set from https://launchpad.net/~nvidia-vdpau/+arc...ld/1146840 and manually install them with dpkg

e.g. :
Code:
dpkg -i nvidia-190-kernel-source_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-libvdpau_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-libvdpau-dev_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-190-modaliases_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-glx-190_190.18.03-0ubuntu1~ppa1_i386.deb
dpkg -i nvidia-glx-190-dev_190.18.03-0ubuntu1~ppa1_i386.deb



does anybody knows, where i can get the 64 version of this files?

cause here https://launchpad.net/~nvidia-vdpau/+arc...ld/1146848 i cant download the files
I had the same issue with my Zotac IONITX-F-E board. After my head was soft fromm hitting the keyboard again and again I took a look at the MB manual. Changed the USB power jumper from 5V to 5Vdual and voila! Resume and standby work perfectly!