Kodi Community Forum

Full Version: [LIVE] setting up "TV SHOWS" using dvd-video structure
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hi- i've looked about and can't find this answer suitable for the Live version of xbmc

my media server has my movies and tv shows ripped onto them from dvd in the Video_TS folder structure with IFO and VOB files. movies are working perfectly, tv shows, not so much... here's first an example of the folder structure:
\\SERVER\Videos\TV Shows\Arrested Development\Season 1\01 - Pilot\VIDEO_TS\ vob & ifo's here..

so i set in the videos screen that the TV Shows folder is type TV and set it with the tvdb.com scraper. and in videos i can scroll through like a file folder and get to the files and watch them there. however, when i get to the TV Shows section instead, i get a list of all of my tv show names and the show description, but they all say 0 episodes and none scrape thumbs.

i'm sure it has to do with the folder structure/vob & ifo's but i don't know where to turn to, to actually fix it (short of re-encoding the whole tv library!)

like i said, i found answers for other platforms that involve i believe an XML file, but on my Live setup (which i have installed to a hard drive, not running off a disc), i don't know where to find that (if it even exists)

thanks for any assistance you can offer
Assuming you have a single "dvd folder" per episode, then you need to setup a regexp to pick them up.

See the online manual for more information - particularly the video library section and advancedsettings.xml

If you don't have a separate dvd folder per episode, then it might be trickier.

How exactly do you have things laid out?

Cheers,
Jonathan
Yeah I have one dvd folder per episode, for example:
\\SERVER\Videos\TV Shows\Arrested Development\Season 1\01 - Pilot\VIDEO_TS\
\\SERVER\Videos\TV Shows\Arrested Development\Season 1\02 - Second Episode\VIDEO_TS\

Not sure what regexp is?
Start reading the online manual.

Assuming they're exactly like that, then you need to add something like this:

<regexp>Season ([0-9]+)[\\/]([0-9]+)[^\\/]*[\\/]VIDEO_TS[\\/]VIDEO_TS.IFO</regexp>

That should allow just the .ifo to be picked up which may be required.
honestly, i'm not a programmer and don't understand the syntax of this... i tried to copy that to make an xml file. i made this:

Code:
<advancedsettings>
<tvshowmatching>
        <regexp>Season ([0-9]+)[\\/]([0-9]+)[^\\/]*[\\/]VIDEO_TS[\\/]VIDEO_TS.IFO</regexp>
</tvshowmatching>
</advancedsettings>

and i put it in the Profile Data folder (at the same level as files like guisettings.xml, sources.xml, etc...) still not working though....all of the shows still say 0 episodes. reading through this manual, a lot of it consists of things i don't understand.
is my file complete?
i appreciate your or any assistance with this...
it would probably help jonathon if you provide a debug log.. again read the wiki for that one and post it at pastebin.com
Nick8888 Wrote:it would probably help jonathon if you provide a debug log.. again read the wiki for that one and post it at pastebin.com

i enabled debugging and i tried to have it search for new content again... but on the Live version, where do i find the xbmc.log file?
Quote:xbmc.log and xbmc.old.log are located here, depending on your platform:
OSX/ATV /Users/<username>/Library/Logs/
Linux /home/<username>/.xbmc/temp/
Windows %APPDATA%\XBMC\
Xbox E:\APPS\XBMC\ (assuming you've installed XBMC in E:\APPS)

it seems that the Live version is not as documented as the other versions. i've tried just searching around the net for an answer too.
so... where on the Live version is the log file?
Live is a linux install, so will be in the linux locations.
It's more of a workaround than a solution but you could use MakeMKV to pull out the individual files from the TV Show DVD and use those instead.

MakeMKV will scan the DVD and show the individual streams, it will retain the original video, audio, chapter & anamorphic data from the DVD.

With individual MKV files named after each episode the TV show library should have no problem scanning them.
ok, so now that i know that it's basically the same place as linux, where do i find /home/<username>/.xbmc/temp/
i don't see that in File Manager...
i know nothing of linux, but i am IT proficient. so if someone shows me how to navigate this, i'd be more than able to get this file and post the log.

honestly, to keep telling me to read the wiki or manual is just getting frustrating, for me and i'm sure for people who constantly respond to the same problems. but for people like myself who don't have much experience with linux, programming, etc.. but want a rich media environment, it's like telling someone to read a manual on atom smashing. i appreciate the help from all, but if the answer is to just read the manual, that really isn't helping me.
when you say File Manager, do you mean xbmc's file manager? It should be in that exact spot, ie "/home/wookietv/.xbmc/temp/" note that the dot (.xbmc) means it is a hidden folder and you will need to enable the option to show hidden files to see it. I haven't used xbmc Live so I'm not sure how you can access the file as most of the underlying os has been removed. You could log in with a ubuntu live cd if you have one lying around but I'm sure someone can tell you a better way than that.

Remember this software has been provided to you for free as is this support (if you can call it that). As you should know reading the manual is a prerequisite for any support questions. However, we have only referred you the manual above as it is written much clearer than we could have. Its only natural for you to not want to read through the manual, as it is for me too, but Im not the one with the problem here.
hallelujah! i found that folder! Big Grin
so now i can submit the log... thanks for letting me know about the hidden files/

http://pastebin.com/ma3b9ced

well, i can see in the log why it's not working, its just a matter of now figuring out how to fix it:

Code:
#
19:47:42 T:2913545104 M:676360192   DEBUG: Hash[tvshows,smb://SERVER/Videos/TV Shows/Arrested Development/]:DB=[],Computed=[]
#
19:47:42 T:2913545104 M:676360192   DEBUG: OpenDir - Using authentication url smb://SERVER/Videos/TV%20Shows/Arrested%20Development
#
19:47:42 T:2913545104 M:676401152   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://SERVER/Videos/TV%20Shows/Arrested%20Development'
#
                             unix_err:'d' error : 'Permission denied'
#
19:47:42 T:2913545104 M:676401152   ERROR: GetDirectory - Error getting smb://SERVER/Videos/TV Shows/Arrested Development/
#
19:47:42 T:2913545104 M:676401152   DEBUG: Sort, sorting took 0 millis
#
19:47:42 T:2913545104 M:676401152   DEBUG: DoScan - Finished dir: smb://SERVER/Videos/TV Shows/Arrested Development/
#
19:47:42 T:2913545104 M:676401152   DEBUG: Process - Finished scan
#
19:47:42 T:2913545104 M:676401152  NOTICE: My Videos: Scanning for video info using worker thread, operation took 00:00
#
19:47:42 T:2913545104 M:676401152    INFO: Video scan was stopped or finished ... restoring FindRemoteThumbs
#
19:47:42 T:2913545104 M:676401152   DEBUG: Thread 2913545104 terminating

btw, as i said, i'm very appreciate of the help i'm given... it's not that at all, it's just that i don't understand a lot that is written in the manual. parts of it may as well be in greek. i can read it over and over (which i have!) and it still doesn't make sense.


edit: ok, i've had minor success... i got one tv show working, arrested development. not exactly sure what i did though?? it all of a sudden brought up a user/password screen which i filled in and then i did an update source and it brought in the episodes. i just can't figure out how to do the same with my other shows :confused2: i did update in the network section my default username/password so it would stop asking me...
i'm seeing this in the log under another show:
Code:
20:25:09 T:2899311504 M:659263488   DEBUG: could not enumerate file smb://SERVER/Videos/TV Shows/Chappelle's Show/Season 1/Episode 12/VIDEO_TS/VIDEO_TS.IFO
does anyone know what that error means exactly?

edit 2: so i got all of my shows working now, except for 2 series, the above error for Chappelle's Show and the same error for the Wire for some reason.
Code:
20:36:08 T:2897169296 M:667889664   DEBUG: could not enumerate file smb://SERVER/Videos/TV Shows/Wire/Season 5/Ep01 - More with Less/VIDEO_TS/VIDEO_TS.IFO

edit 3: figured out what that error means, "could not enumerate...." and fixed it. for example, for the wire one, it fails because of the folder name "Ep01". changing it to "01" fixed it. i guess at that point it's looking for a number to allocate to the episode, so the extraneous wording of Ep throws it off.

anyway, thanks for everyone's input on this!Big Grin
hi... i'm again having a problem with importing tv shows into my libarary.
here's a new pastebin
http://pastebin.com/m651164be

so this time i'm trying to bring in the show The I.T. Crowd... i have all 3 seasons setup exactly the same way as all other shows now, for example:
\\SERVER\Videos\TV Shows\The I.T. Crowd\Season 3\01 - From Hell\VIDEO_TS\files here

it doesn't seem to want to pull in the 3rd season that i just got. the season 1 and 2 were fine, but when i went to update the library, it's not giving me the 6 new episodes. can anything in the log help figure out what's wrong? (btw, i was using tvdb.com but it seems to be done from what i gathered on my own and then confirmed here on the forums. using imdbtv now)
without being a programmer I cant offer you much help but the log does look strange, it recognises the presence of the 3rd season but doesnt seem to get the episode id from them.

I would try removing the series (select the series > context menu > remove from library) and add again. (note thetvdb is down at the moment)

Have you tried to play the season from the files view? (to check whether it is a permissions issue)

looking at the log there is definitely a problem with your install. Im not sure whether it is in relation to the problem you are experiencing though. You seem to be using verison 9.04 babylon final or an svn from soon after? If you are comfortable with updating, maybe try that.

sorry I cant help much more but hopefully someone else can.
removing that 3rd season and adding it again worked, thanks for that suggestion.
btw, tvdb is back up it seems as of tonight. is there an easy way to upgrade without losing all my settings?
thanks a lot!