Kodi Community Forum

Full Version: cpufreq in 9.11a not switching to lowest state
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

just transitioned from my custom gentoo install to xbmclive. It works quite well so far, however, one issue bothers me:

My CPUfreq won't go down to 1600MHZ. My E6300 (PDualCore) has 3 states 1600 2200 and 2800. My XBMClive install remains at 2200 even when idle. Any config option i overlooked? cpufrequtils config is already set to "ondemand" governor. It switched to 1600 on my gentoo install, so it's not my hardware.

Would appreciate if someone could point me in the right direction. Thank you.
Figured it out myself: /etc/default/cpufrequtils contains a line called "minfreq". This is set to 1,8ghz by default. I set it to the lowest state supported by my cpu (1,6) and now it switches down to 1,6 Smile.
well done.. ! Wink
Had the same issue on xbmcfreak-10.08-svn31632-lucid1
Linux XBMCLive 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux

Cpu is an Intel Q6600


Got min freq from doing
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
2394000 1596000

And entered that into /etc/default/cpufrequtils
Code:
ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="0"
MIN_SPEED="1596000"
(MIN_SPEED was default set to 1800000)

and the made a
Code:
/etc/init.d/cpufrequtils restart
to get it work


Thank you for your help Big Grin