Kodi Community Forum

Full Version: AdvancedSettings.xml for TV
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,

I'm trying to figure out how my xml settings should be in the advancedsettings.xml file.

All my tv shows are as at -

e:\tv shows\Mad Men\Season 1\Mad Men - SO1EO1 - Smoke gets in your eyes

So, TV Show Name\Season\Name of show - season0 episode0 - name of episode.

I have created my advancedsettings.xml file and placed it under userdata directory.

<advancedsettings>
<setting>
<tvshowmatching>
<regexp>Season ([0-9]+) - s([0-9]+)e([0-9]+) - [^\\/]*</regexp>
</tvshowmatching>
</setting>
</advancedsettings>

Is this right?

Thanks guys!
You shouldn't need to add anything if that is your naming convention - they should be picked up by default.

Why do you think you need to add anything? Debug log of you scanning your library will be helpful (without your modifications).
Ok, when I go into tv shows under my library it says that I have no episodes or seasons and all the artwork is pixelated so i assumed my shows were not correct format.
PLease see my signature for how to post a debug log in the future.

Looking at what you have posted, its not scanning any directories that contain tv items. How have you set up your sources?

You're also running an old version.
Hi,

Will do that in future sorry for that.

I setup everything in the inital skin under video's so I add the to sources below.

I setup movies as > imdb
Then TV Shows as > TV imdb

I chose not to select any of the options at the bottom except to scan library.
dallasf Wrote:e:\tv shows\Mad Men\Season 1\Mad Men - SO1EO1 - Smoke gets in your eyes

not really fixing your general problem, but i hope the above is just a typo, as it won't work if you replace 0 (zero) with a big O..
oh, and upgrading is there any wiki notes as I couldn't find any on upgrading.

Thanks.
Note what azido said, don't use capital O in season/ep numbering.
Update to 9.11 alpha 1, your build is old.
Then try again with thetvdb.com scraper.

Update is simple, download the Windows binary and run it.

In the future if you have problems, follow the instructions in my sig.
Hi,

I updated to alpha and no changes.

My Tv show structure doesn't use a captial O or an o. It uses a zero = 0.

Are zero's not allowed at all.

Thanks guys for your help.
Hi, running build 24374 on Ubuntu Karmic and having trouble with the scraper for TV-shows. As soon as there is a nfo file for the episode, it picks it up, but if there isn't it cannot find shows or add them to the library.

Code:
14:11:07 T:82332528 M:3520806912   DEBUG: No NFO file found. Using title search for 'smb://user:[email protected]/tv/House/S6/House.S06E06.720p.HDTV.x264-SiTV.mkv'
14:11:07 T:82332528 M:3520806912   ERROR: CVideoInfoScanner::OnProcessSeriesFolder: Asked to lookup episode smb://user:[email protected]/tv/House/S6/House.S06E06.720p.HDTV.x264-SiTV.mkv online, but we have no episode guide. Check your tvshow.nfo and make sure the <episodeguide> tag is in place.

The episodeguide tag is in place. Getting the same on all shows where I add new episodes. I I use an external tool and make it add nfo, XBMC picks them up in the library correctly. Wondering if I should change the search pattern, but according to this thread my structure should be ok.
sho Wrote:Note what azido said, don't use capital O in season/ep numbering.
Update to 9.11 alpha 1, your build is old.
Then try again with thetvdb.com scraper.

Update is simple, download the Windows binary and run it.

In the future if you have problems, follow the instructions in my sig.

Friends don't let friends use Camelot
My head is completely done in.

I have tried everything and can't get anything to load. I obtained a new series of tv show and it registered fine but nothin else does. It all has the same type of path and nothing is downloading except for this one that I just got.

Anybody pleaseeeeeeeeee.
Same advice as last time. Update to newer version, scan again and post full debug log if it still doesn't work.
I've well an truly updated to Alpha. Set content to tvdb. Ran update library.

Even removed tv shows and added again. Same issue.

I posted the error's from the log file. Still nothing.

Thanks

14:35:11 T:5920 M:1371172864 NOTICE: Contents of special://profile/advancedsettings.xml are...
<advancedsettings>
<fanart>
<remove>fanart.jpg</remove>
<add>backdrop.jpg</add>
</fanart>
<dvdthumbs>
<remove>folder.jpg</remove>
<add>folder.png</add>
</dvdthumbs>
</advancedsettings>
14:35:11 T:5920 M:1371099136 NOTICE: Getting hardware information now...
14:35:11 T:5920 M:1371004928 NOTICE: Checking resolution 12
14:35:11 T:5920 M:1370923008 NOTICE: Default DVD Player: dvdplayer
14:35:11 T:5920 M:1370882048 NOTICE: Default Video Player: dvdplayer
14:35:11 T:5920 M:1370841088 NOTICE: Default Audio Player: paplayer
14:35:11 T:5920 M:1370832896 NOTICE: special://masterprofile/sources.xml
14:35:11 T:5920 M:1354661888 NOTICE: initializing playlistplayer
14:35:11 T:5920 M:1354657792 NOTICE: DONE initializing playlistplayer
14:35:11 T:5920 M:1354649600 NOTICE: load default skin:[PM3.HD]
14:35:12 T:5920 M:1345695744 NOTICE: initialize done
14:35:12 T:5920 M:1345695744 NOTICE: Running the application...
14:35:12 T:5920 M:1345679360 NOTICE: ES: Starting event server
14:35:12 T:4560 M:1345175552 NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
14:35:12 T:4560 M:1345171456 NOTICE: UDP: Listening on port 9777
14:35:35 T:5920 M:1313914880 ERROR: Control 402 in window 10133 has been asked to focus, but it can't
14:35:41 T:148 M:1313943552 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting E:\Movies\Notorious (1946)\
14:35:47 T:148 M:1313861632 ERROR: DIRECTORY::CDirectory::GetDirectory - Error getting E:\TV Shows\Seinfeld Bloopers\
14:35:47 T:148 M:1315504128 NOTICE: My Videos: Scanning for video info using worker thread, operation took 00:12
Sorry guys here is a better idea of the log. I removed everything re-added scanned and added to library. This will give you a much better idea of things.

Plus you will be happy to know i used pastebin. yeahhhhhh.

http://pastebin.com/m1f750f95

Thanks Lads
Pages: 1 2