Kodi Community Forum

Full Version: Analogue sound solves stuttering on my ASRock 330!!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys,

Just got an ASRock ION 330 and am already in my 2nd week of configuring XBMC for this puppy. I now just installed 9.11 Alpha 2 and am testing several videos. I tried almost everything possible to get rid of this annoying stuttering (see my xorg.conf below) by using al the valuable feedback from you guys (thanks!!).


I first used HDMI-passthrough for sound to my Onkyo Receiver and had the annoying stuttering. Then I tried something else (do not ask me why, stupid story): just analogue sound (setting in Sound Hardware in XBMC) through an optical cable. No I have a perfect stable picture without any stuttering!! Isn't that weird?? I use the following settings in "Settings - Video - Player":

- VDPAU: On (duh)
- Adjust Refresh Rate: On
- Sync Playback to display: On
- A/V sync method: Video Clock

Made the following changes in my xorg.conf:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  ([email protected])  Tue Oct 20 21:00:15 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       15 - 50
    VertRefresh     48 - 62
#    ModeLine        "[email protected]" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +hsync +vsync Interlace
#    ModeLine        "[email protected]" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync Interlace
    ModeLine        "[email protected]" 74.25 1920 2448 2492 2640 1080 1084 1094 1124 +hsync +vsync Interlace
    ModeLine        "[email protected]" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync Interlace
    ModeLine        "[email protected]" 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
    Option         "DPMS"
    Option         "ExactModeTimingsDVI" "TRUE"
EndSection

# Set A/V Sync method to "Video-Clock"
# Asjust Refresh-Rate "On"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "ModeValidation" "NoEdidModes"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "TwinView" "0"
    Option          "DynamicTwinView" "false"
    Option          "FlatPanelProperties" "Scaling = Native"
    SubSection     "Display"
#        Depth       24
        Modes      "[email protected]" "[email protected]" "[email protected]"
    EndSubSection
EndSection

Any idea how I could get the stutterless picture with Digital Audio??

Your help is appreciated!
-- bump
You need a 24 hertz modeline.
bobo1on1 Wrote:You need a 24 hertz modeline.

and a new xorg.conf. Yours looks really ugly...better start from scretch. Those # seem all wrong to me, and some not commented lines also.
Ok, will try to start from scratch. Thx for the feedback.
So I started with a complete new freshly generated xorg.conf and did nothing with ModeLines whatsoever. Exactly the same problem remains, but I found something else: setting the sound to Digital is not so much the problem, but enabling the "Dolby Digital" and / or "DTS" settings create the stutter. When disabling these settings, all movies play perfect (with only Dolby Surround of course) and I can hear the speed increasing of the video (sound is higher). This fenomenon is I think explained here.

Any ideas on why enabling Dolby Digital and/or DTS creates the stutter? I tried to use sound over hdmi and optical; no difference...Oo
did you remove the sync audio/video settings also?
In order to speed up 24 fps to 25, the audio has to be resampled, and you can't resample when using passthrough because the audio is sent in a compressed format.
rickx Wrote:did you remove the sync audio/video settings also?
Yep... Did not improve anything.
bobo1on1 Wrote:In order to speed up 24 fps to 25, the audio has to be resampled, and you can't resample when using passthrough because the audio is sent in a compressed format.
Thank you for looking into my problem. I am not sure if I understand you correctly though! My TV does not have a 24fps mode, so that is why you are saying it needs to be resampled to 25fps (to match the 50hz)?

And as far as I know, most of my content is not 24fps, and I have consistent problems with all kinds of video-formats!

And to be honest, I do not get why it all needs to be so complicated. I just want my content to play fluently and with Dolby Digital on my TV just like any other mediastreamer these days can do (I actually had one but was tempted by all the extra great features of the XBMC platform...). I really don't get it...
Set the refreshrate to 60 hertz and turn off adjust refreshrate, see how that works.
Actually, I can confirm this stuttering with digital audio also. When I upgraded to alpha2 I wiped my .xbmc dir which defaults sound back to Analog. I forgot to immediately set it back to Digitial for a few days and found my BlueRay dumps of Planet Earth played without stutter. When I switched back to Digital Output (AC3) the stuttering returned. I have set up my xorg.conf to enable 24Hz and mode switching. This happened on my main rig (not Ion) but I'll try to reproduce on my ion setup and notify. This is my xorg.conf, relevant sections only.

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "ModeValidation" "AllowNon60HzDFPModes,NoXServerModes,NoVesaModes"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "ExactModeTimingsDVI" "True"
    Option         "HWCursor" "False"
    Option         "TwinView" "False"
    Option         "NoFlip" "True"
    Option         "DynamicTwinView" "False"
    Option         "FlatPanelProperties" "Scaling = Native"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection