Kodi Community Forum

Full Version: I need help fixing 2 problems
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Guys

I have 2 problems I need help fixing, i've installed latest build on my Asrock 330 ion BD running Ubuntu 9.04.

1. I can't populate my TV Shows folder, I added the source, but the TV Shows folds stays completely empty, I looked at other threads, but they all contain information i already know :-(

2. Some of my movies does not playback sound, while others do:

These play sound:
Madagascar.Escape.2.Africa.720p.Bluray.x264-SEPTiC
Felon.2008.720p.BluRay.x264-SiNNERS

These do not play sound:
The.Taking.of.Pelham.123.720p.BluRay.x264-HUBRIS
Public.Enemies.720p.BluRay.x264-METiS
The.Brothers.Bloom.LIMITED.720p.Bluray.x264-CBGB

the files does have sound on XBMC on my other computer running Windows 7, just not on XBMC on my Asrock, any idea as to what might be wrong?
We need debug logs...
Can you explain how i create such a log?
http://wiki.xbmc.org/index.php?title=HOW...Bug_Report

see the section about generating the right kind of log file with the right info.
KOROR Wrote:Can you explain how i create such a log?

After 69 posts you should already be familar with our wiki and the stickies in our forum....
How are they stored? filenames? folder? nfo files present from MIP?
KOROR Wrote:1. I can't populate my TV Shows folder, I added the source, but the TV Shows folds stays completely empty, I looked at other threads, but they all contain information i already know :-(
Thanks for the last 3 replies, somehow I'm not getting emails when tread is replied to, i will get back to you ASAP :-)
I tried making a log on pastebin:

The first movie Madagascar.Escape.2.Africa.720p.Bluray.x264-SEPTiC played fine with sound, the second movie Public.Enemies.720p.BluRay.x264-METiS did not play any sound, heres a pastebin link:
http://pastebin.com/f67e7ab17

regarding the TV show issue, there is no nfo files in the folders, i thought XBMC was supposed to download these?
Here the folder setup:
TV Series
Curb Your Enthusiasm
Season 7
Curb.Your.Enthusiasm.S07E08.720p.HDTV.X264-DIMENSION
Now I have nfo files containing info as below, still it doesn't show up in TV Shows in xbmc:

ยด╗┐<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<tvshow>
<title>Curb Your Enthusiasm</title>
<year>
</year>
<rating>8.8</rating>
<plot>Each half-hour episode of Curb Your Enthusiasm features semi-improvised footage of David (playing himself) at home, at work and around town, as he gets into predicaments with fictional and real-life personalities.

Candid, unsparing and self-deprecating, Curb Your Enthusiasm brings the off-kilter comic vision of Larry David--co-creator and co-executive producer of one of the most lauded comedy series in TV history, Seinfeld--to HBO.</plot>
<thumb>http://thetvdb.com/banners/posters/76203-1.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/76203-6-2.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/3720-4.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/3720-1.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/76203-0.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/76203-7.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/76203-6.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/3720-5.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/3720-2.jpg</thumb>
<thumb>http://thetvdb.com/banners/seasons/3720-3.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/3720-g2.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/76203-g2.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/76203-g3.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/76203-g.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/3720-g.jpg</thumb>
<thumb>http://thetvdb.com/banners/graphical/76203-g4.jpg</thumb>
<thumb>http://thetvdb.com/banners/text/3720.jpg</thumb>
<thumb>http://thetvdb.com/banners/blank/76203.jpg</thumb>
<fanart>http://thetvdb.com/banners/fanart/original/76203-2.jpg</fanart>
<fanart>http://thetvdb.com/banners/fanart/original/76203-4.jpg</fanart>
<fanart>http://thetvdb.com/banners/fanart/original/76203-3.jpg</fanart>
<fanart>http://thetvdb.com/banners/fanart/original/76203-5.jpg</fanart>
<runtime>30</runtime>
<mpaa>TV-MA</mpaa>
<genre>Comedy</genre>
<premiered>2000-10-01</premiered>
<studio>HBO</studio>
<id>tt0264235</id>
<tvdbid>76203</tvdbid>
<sortorder>default</sortorder>
<language>en</language>
<episodeactorsource>tvdb</episodeactorsource>
<tvshowactorsource>tvdb</tvshowactorsource>
<actor>
<name>Larry David</name>
<role>Larry David</role>
<thumb>http://thetvdb.com/banners/actors/44099.jpg</thumb>
</actor>
<actor>
<name>Cheryl Hines</name>
<role>Cheryl David</role>
<thumb>http://thetvdb.com/banners/actors/44097.jpg</thumb>
</actor>
<actor>
<name>Jeff Garlin</name>
<role>Jeff Greene</role>
<thumb>http://thetvdb.com/banners/actors/44098.jpg</thumb>
</actor>
</tvshow>
Ok so I've looked at the log and even though i'm no expert I think I figured out the problem or at least why some movies have sound and some don't, the movies with DTS sound is the ones that don't produce sound, AC3 and other play just fine. Can someone help me fix the problem? Like I wrote earlier, the movies play just fine in XBMC under Windows 7 on my other computer.

I still haven't figured out why TV Shows aren't getting populated, so if anyone has some input as to what might be the problem i would be grateful :-)

PS. I noticed that when starting XBMC under Ubuntu on my HTPC it always needs to be started twice, the first time it looks like it's opening "the icon widening" but then nothing else happens, the second time I click the icon, XBMC starts fine, I posted 2 logs below:

XBMC "crash":
http://pastebin.com/f30b7e9df

XBMC loading fine:
http://pastebin.com/f2501dd44
Sound problem fixed, found this thread:
http://forum.xbmc.org/showthread.php?p=442191

Quote:I did some more playing around with the audio settings and found you can enable Dolby without affecting the HDMI output.

-Dolby Digital (AC3) Capable receiver-----on
-DTS Capable Receiver-------------------off

Make sure DTS is off or you will hear didley.