Kodi Community Forum

Full Version: Upgrading to Alpha2 - xbmc-eventclients-common
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So, I'm living dangerously and attempting to upgrade to alpha2 xbmc-live through apt-get. I'm running on an ASRock ION 330...

The upgrade gives me the following error which seems to be a problem with update-python-modules:
Code:
[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up xbmc-eventclients-common (9.11~alpha2-karmic1) ...
Usage: update-python-modules [-v] [-c] package_directory [...]
       update-python-modules [-v] [-c] package.dirs [...]
       update-python-modules [-v] [-a|-f|-p]

update-python-modules: error: /usr/share/python-support/xbmc-eventclients-common.public is not a directory
dpkg: error processing xbmc-eventclients-common (--configure):
subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of xbmc-eventclients-dev:
xbmc-eventclients-dev depends on xbmc-eventclients-common (= 9.11~alpha2-karmic1); however:
  Package xbmc-eventclients-common is not configured yet.
dpkg: error processing xbmc-eventclients-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-eventclients-j2me:
xbmc-eventclients-j2me depends on xbmc-eventclients-common (= 9.11~alpha2-karmic1); however:
  Package xbmc-eventclients-common is not configured yet.
dpkg: error processing xbmc-eventclients-j2me (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xbmc-eventclients-ps3:
xbmc-eventclients-ps3 depends on xbmc-eventclients-common (= 9.11~alpha2-karmic1); however:
  Package xbmc-eventclients-common is not configured yet.
dpkg: error processing xbmc-eventclients-ps3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency prNo apport report written because the error message indicates its a followup error from a previous failure.
                                             No apport report written because the error message indicates its a followup error from a previous failure.
                                                                       No apport report written because MaxReports is reached already
                                                     No apport report written because MaxReports is reached already
                                   oblems prevent configuration of xbmc-eventclients-wiiremote:
xbmc-eventclients-wiiremote depends on xbmc-eventclients-common (= 9.11~alpha2-karmic1); however:
  Package xbmc-eventclients-common is not configured yet.
dpkg: error processing xbmc-eventclients-wiiremote (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
xbmc-eventclients-common
xbmc-eventclients-dev
xbmc-eventclients-j2me
xbmc-eventclients-ps3
xbmc-eventclients-wiiremote
E: Sub-process /usr/bin/dpkg returned an error code (1)

I know it's unsupported given the current instability, but any thoughts? Thanks!