Kodi Community Forum

Full Version: XBMC 9.11 (alpha2) + Firefox Flash (via Launcher) HDMI Sound
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

I wonder if someone can help, i'm struggling to get Flash sound in Firefox on my Minimal Ubuntu XBMC installation. I only seem to be able to get one of the other!! so frustraiting, so here goes:

Acer Aspire Revo (ION)
Ubuntu 9.04 Minimal
XBMC 9.11 Alpha2
Launcher Plugin
Firefox 3.0 (via Launcher)
Flash (latest version via apt-get)

I've set the environment variables
FLASH_FORCH_ALSA=1
FLASH_AUDIODEBUG=1

Now, a /etc/asound.conf of:
Code:
pcm.!default {
type plug
slave.pcm "hdmi"
}
Gives me lovely HDMI sound in XBMC, but not in Flash via Firefox :-(

And a /etc/asound.conf of:

Code:
defaults.pcm.device 3

Gives me lovely HDMI sound in Firefox Flash!! But not XBMC :-(. I get 'Failed to initialise audio device'.

Is it even possible to have both?

Thanks in advance for any help!

J
Anyone got an Acer Revo who has managed to achieve the same? I'm pulling my hair out here!
My setup is also a Acer Revo 3610 and I am outputing to my Sony TV via my Sony Reciever. I was having the same issue and found this solution here and here.

I changed my .asoundrc file to:
Code:
pcm.dmixer {
type dmix
ipc_key 1024
ipc_key_add_uid false
ipc_perm 0660
slave {
pcm "hw:0,3"
rate 48000
channels 2
period_time 0
period_size 1024
buffer_time 0
buffer_size 4096
}
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

Now sound works over HDMI in both XBMC and in Firefox/Flash as well as xmame.

Additional info to help others here:
Code:
[email protected]:~$ cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.21.
Compiled on Nov 29 2009 for kernel 2.6.31-15-generic (SMP).

[email protected]:~$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
Mate you're a legend, works perfectly!!! Now, if only Adobe would give us VDPAU acelleration under linux!
By the way, when you launch firefox via the 'Launcher' plugin does it go fullscreen? Mine doesnt, it appears top left?? And i can't make it any bigger. If i click the fullscreen button on a flash video it fills the screen though? Any ideaS?
nevermind. thanks for this!!
Hi guys,

if the settings from Zarquon doesn't work for you (it won't work for me either), just add to your ~/.asoundrc or /etc/asound.conf like musti already said:
Code:
defaults.pcm.device 3

Sound in Flash will work correctly, to get sound in XBMC just change the audiosettings from hdmi to default in XBMC.

- linkin
Hi,
I have a fresh install of XBMC 9.11 running on Ubuntu Karmic minimal (installed by this tutorial: http://peter.wurmsdobler.org/bricols/xbmc.html.) Now I would like to have a possibility to use a web browser launched in XBMC. I couldn´t find a simple HowTo for that purpose. I´m a more-or-less newbie with Linux so what I really need is a list of commands/very basic and simple tutorial how to make this happen. I would really appreciate your help.

-t