Kodi Community Forum

Full Version: [LIVE] Hdmi handshake issues (ION)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I have built a dedicated XBMC Live-box based on the Point of View ION-MB330 (Atom 330, nVidia ION). My main problem is this: the motherboard only outputs video to hdmi when my tv is turned on during boot-up. If I turn the my ION-pc on while my tv is off, there is no way I am getting an image afterwards. I am assuming this is a hdmi handshake problem; is there any workaround or fix for this?
i got the same problem, but there is also no image when i resume xbmc from standby with tv on
but it shows me the bootsplash if i shut it down
I don't use standby (my htpc is also my fileserver/torrentbox) but this handshake issue really bugs me out.

I think I will try to connect hdmi through a dvi-hdmi-dongle on the dvi-port and output the sound through a digital optical cable. Not as pretty as one hdmi-cable, but I need this to work. Let's hope dvi doesn't have handshake issues... :-S
Yeah its annoying. You'd think there would be another way, but then again so far there doesn't seem to be.
I had this very same problem and when I formatted and installed ubuntu karmic, the issue went away. I believe it was an X windows issue on versions of linux before 9.10. Either way it works perfect on my Zotac ION system now.

I can turn the PC on without the TV ever coming on, and it loads up fine.
Qroach Wrote:I had this very same problem and when I formatted and installed ubuntu karmic, the issue went away. I believe it was an X windows issue on versions of linux before 9.10. Either way it works perfect on my Zotac ION system now.

I can turn the PC on without the TV ever coming on, and it loads up fine.

Hmm, if my dvi-hdmi-dongle workaround doesn't do the trick, I'll consider doing a minimal Ubuntu install. Thanks!
I'd be willing to bet it doesn't work as I think the issue is purely Xwindows based.
Yeah, as an earlier poster said, this is down to the xorg.conf. In newer version of Ubuntu, xorg tries to be too clever, autodetecting the attached hardware at each boot. This can cause problems if no display is attached when booting. In some variants of Ubuntu betweem 8.04 and 9.10 this caused xorg to flake out, because it couldn't detect a display....

However, I think newer versions of xorg have regressed this feature, since it was being too clever for its own good. So, upgrading to the newest version of Karmic 'should' fix your issue, though maybe not. In any case, its an xorg issue.
I had the same issue. You can try to fix this by adding two things to your xorg.conf

First find out on which channel your tv is connected. You can do this by killing X with:
Code:
kill -9 `ps ax | grep xbmc.bin | grep -v grep | awk ‘{print $1}’`
and starting it with:
Code:
sudo X -verbose 6 > ~/xlog.txt 2>&1

The xlog.txt should give a debug and should contain lines like:

Code:
(II) NVIDIA(0): --- Modes in ModePool for ONK TX-SR507 (DFP-1) ---
(II) NVIDIA(0): "nvidia-auto-select" : 1920 x 1080 @ 50.0 Hz (from: EDID)
(II) NVIDIA(0): "1920x1080" : 1920 x 1080 @ 50.0 Hz (from: EDID)
(II) NVIDIA(0): "1920x1080_50" : 1920 x 1080 @ 50.0 Hz (from: EDID)
(II) NVIDIA(0): "1920x1080_60" : 1920 x 1080 @ 60.0 Hz (from: EDID)

Next step is adding a line with the ConnectedMonitor parameter, see below

Code:
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
[b]Option “ConnectedMonitor” “DFP-1″[/b]
    SubSection "Display"
    Depth 24
    Option "DynamicTwinView" "false"
    EndSubSection
EndSection

Make sure your there's a match between the config and value found in the debug log. It's either DFP-0 or DFP-1.
By adding this line X outputs always to the same signal

You might give this a try. If it doesn't work try adding the next steps to your configuration.

With the debug log still there you can make a edid file with the following commandline:

Code:
nvidia-xconfig -extract-edids-from-file=xlog.txt -extract-edids-output-file=tv-edid.bin

Put the tv-edid.bin file on a place somewhere on your system, open the xorg.conf and add the following line to the Device section:

Code:
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
[b]Option "CustomEDID" "DFP-1:/home/xbmc/tv-edid.bin"[/b]
EndSection

Make sure the path is set correct. With these lines added X recognizes the correct signal of your receiver for example! Switch everything off (receiver and so on and see if this works). Your resolution might be very low but at least your screen should display something.

Additional you can add the correct modlines to your xorg.conf. If you do so your screen will also display a correct resolution when turned on!

http://www.mythtv.org/wiki/Modeline_Database

I added modelines with only 1080p, which causes X to display the correct resolution after a cold reboot.
@ehrnam:

Option “ConnectedMonitor” “DFP-0″ works for me in xorg.conf, I now get output to my tv even if my XBMC-pc is already running. However, the resolution gets set to 640x480 maximum (with no option to increase the resolution in XBMC Live until I reboot).

So I assume I have to force a resolution through the ModeLine-option? Where exactly in the xorg.conf-file do I place this line?
Hmm, let me be more specific. Here is my xlog.txt, where you can see that my monitor is being recognized as DFP-0. Even though my tv is now recognized even when XBMC has already been turned on, I tried following your other steps. However:

Code:
nvidia-xconfig -extract-edids-from-file=xlog.txt -extract-edids-output-file=tv-edid.bin

Gives me:

Found 0 EDIDs in "xlog.txt".

I still tried to force the mode by changing:

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    [b]ModeLine       "1280x720_50.00" 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync[/b]
    Option         "DPMS"
EndSection

But it doesn't change the resolution being set to 640x480.

Any ideas?
Option “ConnectedMonitor” “DFP-1″ worked for me and I still get 1080p. I've been looking for this information for ever!

Thanks!!!
x5nder Wrote:Hmm, let me be more specific. Here is my xlog.txt, where you can see that my monitor is being recognized as DFP-0. Even though my tv is now recognized even when XBMC has already been turned on, I tried following your other steps. However:

Code:
nvidia-xconfig -extract-edids-from-file=xlog.txt -extract-edids-output-file=tv-edid.bin

Gives me:

Found 0 EDIDs in "xlog.txt".

I still tried to force the mode by changing:

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    [b]ModeLine       "1280x720_50.00" 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync[/b]
    Option         "DPMS"
EndSection

But it doesn't change the resolution being set to 640x480.

Any ideas?

got the same issue, did you get it working now?
pregi Wrote:got the same issue, did you get it working now?

Nope Sad

I am hoping erhnam has a solution...
x5nder Wrote:@ehrnam:

Option “ConnectedMonitor” “DFP-0″ works for me in xorg.conf, I now get output to my tv even if my XBMC-pc is already running. However, the resolution gets set to 640x480 maximum (with no option to increase the resolution in XBMC Live until I reboot).

So I assume I have to force a resolution through the ModeLine-option? Where exactly in the xorg.conf-file do I place this line?

Yep, try to force! That's what I did!
Pages: 1 2 3