Kodi Community Forum

Full Version: [Live] XBMC 9.11 Beta 2 - Suspend/Wake Issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Under the current (stable) version of XBMC I am able to Suspend/Wake from the power button or MCE remote by default (no changes needed to be made to the '/proc/acpi/wakeup' settings). After installing Beta 1 (fresh install, new hard drive) I noticed although I could suspend and wake once via the power button, any subsequent attempts to suspend via the power button (or on screen shutdown menu) results in the an instant wake. I checked the /proc/acpi/wakeup settings and everything is disabled (except for the power button, which is '*enabled' by default). I did a fresh install of Beta 2 and the problem continues.

I don't understand why it will suspend properly the first time, but never again until I do a complete reboot. Any assistance would be greatly appreciated!

Log: http://pastebin.com/m4fae98d5

EDIT: FYI Using a Zotac n330 + Ion board, 80gb SATA hard drive, HP MCE Remote, installed XBMC via DVD drive.

EDIT: Solved! See solution below:

Tim. Wrote:Boot up XBMC Live
Ctrl+Alt+F2
Login with username/password
sudo nano /boot/grub/menu.lst
Locate the first boot system (Currently labeled ubuntu, not XBMCLive)
Add usbcore.autosuspend=-1 to the end of the 'kernel' line of text
Ctrl+Alt+Delete to reboot
Your suspend now works as expected!
I have exactly the same problem on a p5n7a-vm. Fresh install from CD.
Same issue here, can sleep, cannot resume. 9.11 Beta2 Live CD on USB
I have the same issue on my Revo with fresh install of beta 2.
Those that cannot get it to wake at all most likely need to follow this:

http://wiki.xbmc.org/?title=Enable_Wake-On-Device

Probably missing a line like this:
echo USB0>/proc/acpi/wakeup

in your rc.local file
Will it make machine wake up on any button from remote?

gabbott Wrote:Those that cannot get it to wake at all most likely need to follow this:

http://wiki.xbmc.org/?title=Enable_Wake-On-Device

Probably missing a line like this:
echo USB0>/proc/acpi/wakeup

in your rc.local file
Since there are SOOOOO many of us out here with ION boards, is there a chance that the final live disk will detect it (or include an install option) tailored for IONs to fix all these problems?

I know its not easy to ask "can you make something special for my ultra custom system", but in this case there are a ton of ION boards that are ALMOST identical.

Kevin
gabbott Wrote:Those that cannot get it to wake at all most likely need to follow this:

http://wiki.xbmc.org/?title=Enable_Wake-On-Device

Probably missing a line like this:
echo USB0>/proc/acpi/wakeup

in your rc.local file

I have got the same problem on Live Beta 2 and Zotac Ion n330. I followed this wiki guide and resume works only once, any other time causes instant resume. Using wireless mouse and keyboard combo.
I having another issue is: when I press "power" button, XBMC shutdown my HTPC fully instead of sleep. If I select sleep from menu, I can wake it up by following the wiki page, but yes, only once, next time wake up from sleep, the screen frozen.

Anybody know how to user power button to make HTPC sleep? it works fine in Windows 7.
I've also got similar issues with my Asrock ION 330HT. I can put the system to suspend just fine with the power button. Resuming however is not possible. My external (MCE) IR receiver is responding (LED) after pushing the power button, but the system itself is not resuming.

I use XBMC Live 9.11 Beta1.
As was stated above if your running the beta version of XBMC Live you need to edit the rc.local file.

The quickest way to do this is through WinSCP.

Download and install it, look in its folder for a putty application and run that.

Quote:Step 1) Start Putty and type in the IP address of XBMC Live to connect.
username and password = xbmc

Step 2)Type in this command sudo passwd root this will prompt you to change the root password so pick xbmc as the password.

Close Putty. The purpose of Putty is to give us root access so you can modify the files of XBMC remotely in Winscp otherwise it would not let you.

Step 3) Now start Winscp and in the hostname enter in the XBMC IP address
username = root password = xbmc

Now browse in WinSCP to the etc folder and find the rc.local file and open it in WinSCP editor add the following
echo USB0 > /proc/acpi/wakeup

Save changes by clicking the floppy icon, close WinSCP and reboot XBMC Live.

It should if all went according to plan be working normally for suspend/resume with the Windows media center remote at least.
For my Asrock, I had to make sure that the IR Receiver was actually in USB0 as well. USB2 resulted in the immediate wake issue.
Starstream Wrote:As was stated above if your running the beta version of XBMC Live you need to edit the rc.local file.

The quickest way to do this is through WinSCP.

Download and install it, look in its folder for a putty application and run that.



Now browse in WinSCP to the etc folder and find the rc.local file and open it in WinSCP editor add the following
echo USB0 > /proc/acpi/wakeup

Save changes by clicking the floppy icon, close WinSCP and reboot XBMC Live.

It should if all went according to plan be working normally for suspend/resume with the Windows media center remote at least.

I'm not even talking about the remote. Just the power button. After choosing suspend from the shutdown menu, the power button SHOULD wake up the device. It does. Then I try it again, shutdown->suspend. Instant wake.

Turing on USB0 will not resolve this issue (even though I went ahead and tried anyway). I repeat from my first post, no devices are turned on for wake except the power button, which is listed at '*enabled.'

So, any other ideas as to why this continues to happen?
For those with Zotac mobos I think the earlier versions had problems with waking from usb. Can't remember where I read it though.
Yes but this is not one of those models (later revision), but thanks for the input!
Pages: 1 2