Kodi Community Forum

Full Version: Adding external drive to XBMC Live
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've installed XBMC Live (version 9.11 RC1) onto an Asrock ION. When I try to 'Add Source' the usb drive that is plugged into the Asrock does not show up on the list. How can I add this source? Thanks!
Should already show up by what ever you named the volume as. If you browse the file manager you should see you name there , no need to add source as it is auto mounted.
I've tried attaching a western digital 1tb drive (wd10000 series) and a usb drive and neither show up under the new share list when browsing. Any ideas on why this isn't working?
I had issues with rc1 not showing my usb drives. I had to downgrade to beta 2 on my acer revo to fix it.
FYI, this is already fixed. Next release will mount your drives properly.
Thats great to know. I was having issues with this. On every start up it would mount my external drive diffirently. Sometimes it would be mounted as "External Drive" and sometimes "sdb1".
OK, good that it's known and will be fixed.

Does that mean that the fix will occur in 9.11 RC2? Or will there be fixes in between?

If not until RC2, is there any way of manually mount the USB's or any way to edit something that will fix the problem until then?

/PerM...
This worked for me...

http://forum.xbmc.org/showthread.php?p=4...post461708

You need to add the following to advancedsettings.xml:

Code:
<advancedsettings>
    <handlemounting>true</handlemounting>
</advancedsettings>

If the file does not exist, create it in the UserData folder.

John
I also managed to get around this. But I did it according to the description found here:

http://forum.xbmc.org/showthread.php?tid=50489

This is actually to get internal drives to show up, but it also worked for the USB drive.

/PerM...

p.s. I used option 2, editing the menu.lst file.
vdrfan Wrote:FYI, this is already fixed. Next release will mount your drives properly.

Let's hope it will mount USB in async mode to.
All 9.11 builds I've test are mounting usb in sync mode. This make it very slow when saving data to USB devices.

cheers.
I'm sorry if I come across as a complete idiot here, but how exactly would I go about creating/editing the advancedsettings.xml? If I wanted to do it through XBMC Live, I'd have to exit XBMC and use command line, which with my knowledge would get me about as far as opening the UserData directory. The only other option I see is to download some sort of Linux LiveCD with a GUI and the ability to read/write to XBMC's ext4 partition.
the location is /home/xbox/.xbmc/userdata/advancedsettings.xml

use ftp or scp to transfer a file on (from external PC)

use an external pc with "putty" to log onto machine.
then create the file using
Code:
pico /home/xbox/.xbmc/userdata/advancedsettings.xml

if you really have to you can exit xbmc and do it on the htpc via the above command.

pico is an easy to use editor. arrow keys, backspace etc work. ctrl-x to exit and make sure you say yes to write the file out or overwrite changes if editing an existing one.