Kodi Community Forum

Full Version: Resolution/Output Problem, can't change output to anything but 1080p
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey folks,

been playing around with my XBMC setup today, and wanted to try 720p instead of the usual 1080p I use with my Full HD 46" Plasma.
So I tried changing the resolution in XBMC settings. XBMC seems to scale the resolution, but still my TV receives a 1080p signal when selecting 720p in XBMC.
After that I tried changing my desktop resolution in Ubuntu 9.04. Setting 1280x720 there also scales the screen, but still the ouput, or better said input on the TV tells me it receives 1080p.
Am I missing something here? I would really like to be able to change the output of my HDMI port to something else than 1080p.

Here's my xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Thu Apr 16 17:18:41 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
# Modeline "1920x1080" 148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "RegistryDwords" "PowerMizerLevelAC=0x3"
Option "RegistryDwords" "PowerMizerLevel=0x3"
Option "ExactModeTimingsDVI" "True"
Option "UseEDIDFreqs" "True"
Option "NvAGP" "1"
Option "HWCursor" "false"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEvents" "True"
Option "TripleBuffer" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "False"
Option "RenderAccel" "True"
Option "DPI" "100 x 100"
Option "DynamicTwinView" "False"
SubSection "Display"
Depth 24
EndSubSection
EndSection

thanks

boba

EDIT: solve by adding

Option "FlatPanelProperties" "Scaling=Native"

to my xorg.conf