Kodi Community Forum

Full Version: XBMC won't start (ubuntu64 ati hd5770 w binary drivers)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all

Long story short:

XBMC installs nicely on Ubuntu 9.10 64-bit on an AMD PhenomII X4 965 (fresh install)

When I try to run the program I get a black screen with just an XBMC-styled mouse cursos which I can't move. The only thing I can do is CTRL-ALT-F1, login and then "killall xbmc.bin"

- The CPU isn't running at 100%.
- I tried using different Catalyst-versions
- Google-earth and Sauerbraten works (so 3D stuff should be ok)
- XBMC-logfile looks rather normal, though it has 1 error in it (ERROR: GLX: Same window as before, refreshing context)
- I tried starting in different resolutions
- Video card is an Asus board with a HD5770 GPU (1GB) (PCI-expres)
- I haven't seen anyone post a problem that resembles mine

Is there anything I can do to get it working (or to give developers more information?)


Thanks in advance for your help


Greetings,

Fonsch
I just upgraded to the latest apt version and also tried to compile the latest svn and am seeing this same problem. I'm compiling with debugging now and will see if I can get a log file.

I'm running ubuntu 9.10 with the latest nvidia beta drivers..

gosquad
I'm trying 9.11 on my x86_64 karmic pc with nvidia, and it fails to launch the same way. Mine is fairly exotic, dual 7950's with 4 monitors, 2x2 twinview using xinerama and no compiz/direct render desktop to keep it working. Direct rendering applications always have issues with it, though some games do work in gl mode full screen between the twinview sets, but xbmc seems to not.

The crash log complains of this which seems unable to deal with a lack of xrandr with xinerama, with this:

13:05:07 T:140246987941952 M:5209157632 ERROR: CXRandR::Query - unable to open xrandr xml
13:05:07 T:140246987941952 M:5209157632 NOTICE: Setup SDL
13:05:07 T:140246987941952 M:5207896064 ERROR: CXRandR::Query - unable to open xrandr xml
13:05:08 T:140246987941952 M:5208268800 ERROR: CXRandR::Query - unable to open xrandr xml
13:05:08 T:140246987941952 M:5208236032 ERROR: CXRandR::Query - unable to open xrandr xml

Are you getting the same?

When i launch xbmc via command line or menu, it'll try to full screen across all 4 monitors and die badly with the crash logs produced, and via cli it gives this:

[email protected]:~$ xbmc
Xlib: extension "RANDR" missing on display ":0.0".
Xlib: extension "RANDR" missing on display ":0.0".
RandR extension missing
Xlib: extension "RANDR" missing on display ":0.0".
RandR extension missing
Xlib: extension "RANDR" missing on display ":0.0".
RandR extension missing
Xlib: extension "RANDR" missing on display ":0.0".
RandR extension missing
WARNING: Unhandled message: interface=org.freedesktop.DBus.Introspectable, path=/, member=Introspect
/usr/bin/xbmc: line 88: 9822 Segmentation fault (core dumped) /usr/share/xbmc/xbmc.bin "$@"
Crash report available at /home/user/xbmc_crashlog-20091227_193351.log

Seems there should be some handling to figure out what kind of display environment it's presenting (for exotic/weird configs like this) vs. relying on xrandr, or can figure it out in light of its absence. I can provide logs if it helps, though this seems like it might be more common a problem.
Mine's not actually crashing.. it just shows a black screen and keeps running. I have to manually kill it to get it to stop.

I'm trying to get logging working, but it doesn't seem to be creating it anywhere. I've added <loglevel> to my advanced xml. Should it be in my ~ dir? or /tmp? or the pwd?
well i just compiled the latest svn and everything seems ok again. tried reinstalling the apt version and i still get the black screen. I guess something may have been fixed in the last day or so.

gosquad
@mikus: I don't get any errors, since XBMC doesn't actually crash (like gosquad says).

I'll try to compile the latest svn and let's hope that that'll fix it.

BTW: I just have one screen, no fancy Xinerama or Xrandr
I can't compile the source (some weird VDPAU error), so I'll have to look into that one first.

Meanwhile I noticed that the screen doesn't turn black instantly, but I can see the XBMC letters for a fraction of a second.
To me some of this problems sounds like ubuntu problems and not xbmc problems. Maybe related to xorg config/server. However im not an expert.

Creating a usb-live pen and booting from it could rule out problems with your hardware. If the usb-live works fine your HW is supported by the latest build.
i have the same problem as the original poster.

just got my new fanless 5750, and everything else works (open arena and other 3d stuff).

but when i start xbmc i see the xbmc logo and then the screen turns black and the mouse coursor apears. it doesnt move, althoug i can move the mouse to the other screen and kill xbmc from there :-)
in the xbmc.log its the same fonsch has.

i realy need help here...

@fonsch since your last post was 2 weeks ago, did you managed to get it working?
with the latest propietary driver directly from ati i got it working. (10.1)
its not running that good but at least it starts...
I also got it running using catalyst 10.2 Works like a charm now

@mniewiera: thanks for the PM, I forgot about this thread Smile
fonsch, no problem :-)
currently i also use 10.2 (waiting for 10.3) and have some (smaller) problems.
is videoplayback working fine for you?
i always get this "tearing" in videos, no matter if hd or sd, pal, ntsc, vsync on or off...

you got the same?
Do I get the same? Yes and no.

I have two ATI-based systems here, both running Ubuntu 9.10 64bit and the Catalyst 10.2 driver. One system has the 5770-card and the other an integrated 3200.

The 5770 has no noticeable tearing, where the 3200 has.
The XBMC settings for my 5770 system (Video-settings, 'playback' item) are
Render method -> basic shaders (ARB) (didn't try to change this one yet)
Use pixel buffer objects -> check
Adjust display refresh rate to match video -> check
Sync playback to display -> check
A/V sync method -> Video clock (Resample audio)

The only drawback is that the audio sounds 'slowed down' during the first few seconds of a movie (due to the resampling), but after that it all runs fine. For the record: my CPU is a Phenom II 965.


When I apply these settings to my other machine I'm not quite so lucky: I can't get back in the menus when I stop a movie (process hangs hard). I have to disable the "Sync playback to display option" to get it working normally. I also have to revert to software rendering which (in my opinion) reduces image quality a little bit. Since that system is connected to an old big-screen CRT television, it's not very noticeable. This second system has another (minor) flaw: animations like scrolling menu-text or the audio-visualisations don't run smooth. They lag a bit and then they speed up again, lag again, etc etc
thank you for posting your xbmc settings.
i tried them but it doesnt help.
thats not surprising, because i got this tearing with other players as well. (ubuntu standard video player, vlc and others).
with catalyst 10.1 it was worse, 10.2 noticeably reduced the tearing, but its still there.
i checked and tried every setting in the catalyst controll center with different results.
in the end, i dont bother any more...
its surprising how fast you can get used to this :-(

but in a few days my new 27" i7 imac gets deliverd, so i realy dont care anymore ;-)
i got a good feeling xbmc will run there a "bit" better than on my current system/configuration hehe