Kodi Community Forum

Full Version: mythicalLibrarian - a tool to build Movie and TV Show library from MythTV recordings
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Ok, then I've done what I can. I have put in a request to turn the word "and" into "%26" on failed scrapes, as a backup. Reference: http://forum.xbmc.org/showthread.php?tid=67569

Not all file systems handle "&" in the file name, but they all handle "and". %26 is the web friendly version of &, and the only way to put the data into thetvdb.com for recognition. This would be a XBMC issue as a library should be human readable, the computer should turn the human readable stuff into computer stuff. "and" "&" "%26" "#38;" and "&" are different file systems handling of "and"
well, i spoke to soon - i tried one more permutation which worked. renaming the files (& Show directory) to Law & Order Special Victims Unit results in a tvdb match to Law & Order: Special Victims Unit. The colon was throwing it off, but interestingly it shows up in my xbmc library with the colon intact in the show name.

Moreover, i've tried this in both windows and mac XBMC environments with same results.

Guessing this was tvdb developers simple fix for fact that not all file systems accommodate punctuation (at least : ) in file names?

So currently, mythicalLibrarian is writing "&" as "and", and for this show we need to drop the colon from the name. Is this too much of a corner case to fix?

if so, see if this logic on my end makes sense to you...

another thing i found poking around in tvdb... i guess because there's no exact match for the full Law & Order Special Victims Unit title, ML can't simply get the series ID (it returns a page and a half of various unrelated titles although the title of interest is on the page about 1/4 way down)... but i found that if i searched instead just for Special Victims Unit, it returns just the series info in question.

So perhaps what i need to do is create a show translation where:
Law & Order: Special Victims Unit = Special Victims Unit, let ML process that and find the series, let it write out the files, and then i simply create another script to move and change the names of the files, which effectively drops the colon out of the name, if needed, and ensures the name uses "&" instead of "and". I'd only run this script for this show...
Let me wrap my head around this for a bit.

Make sure I'm understanding what is going on here... XBMC does not recognize Law and Order. mythicalLibrarian translates Law & Order into Law and Order. XBMC has a problem with Law & Order: Special Victims Unit.

I will come up with some sort of work-around for this. using & in bash is a control charactor.
you have it correct... & taking it one more step, xbmc does recognize Law & Order Special Victims Unit (no colon)

thanks, jay

I have yet to get this working, but I also havent spent much time with it yet. I am getting errors writing the files over to my nfs mount I believe. I should be able to get that resolved fairly easily.

I had another question. For my xbmc boxes, is there a way to set the username and password? Can I just set that as part of the URL (user:[email protected])?

^^ Yes that is the way to do it.
Ok, I'm going to tr -d ":" for now as ":" is not supported on fat32. I would like to know of any other problems which occour
A direct search of thetvdb.com on their website shows that the special charactor ":" is required, however a API search does not require it. Sweet.

Just taking some more notes.. control charactors that need to be removed : ! ` < > | \ / : ' "
jaygardner Wrote:you have it correct... & taking it one more step, xbmc does recognize Law & Order Special Victims Unit (no colon)

thanks, jay
so just to be sure XBMC WOULD recognize this properly correct?
/home/mythtv/NAS/Video/shows/Law & Order Special Victims Unit/Law & Order Special Victims Unit.S11E12 (Shadow).mpg
yes - it did on both my mac and windows xbmc instances.
That's very interesting. I don't understand how. I can't get that to scrape via API to TheTvDb.com. I've sent it a few times and tried a few different things. XBMC must send out part of the file name and then process the resuts for some kind of best match after it receives the list. Very interesting.

Posting new beta to sourceforge
Thats why i was wondering if its a corner case...

interestingly, thougth, the series name shows up in xbmc with the colon in its name... but if i rename the show files and directory to contain the colon on my myth backend, then xbmc doesn't seem to find anything.

Would a debug log from xbmc help? i could delete the series from my xbmc library, and then do a library update in both cases (names with colons, names w/o colons...)

Actually, i just looked at the xbmc debug log and used the query on the web like xbmc did - and it returns differently: try this query:

moreover, putting a colon in that search or %3A doesn't change the results...
Yeah, it's kinda wierd. I think XBMC searches for the first word longer then 3 characters, maybe the first or a string of two which is the longest, which would cause this search to fail as the word is "Order:" not "Order". After the search, it could delete all of the special characters and then proceed as usual with a download of series ID. This may be a fluke with special characters in the first few words.
One of my paths has a space in the folder (/home/tim/media/TV Shows) I get errors that file /home/tim/media/TV doesnt exist. I tried escaping it as /home/tim/media/TV\ Shows and get the same result.

How should I enter that into the script?
I just made a few modifications and updated mythicalLibrarian to handle spaces. Get the new version here: https://sourceforge.net/projects/mythicallibrari/files/

Let me know if there are any more problems. This is exactally why I am keeping this in beta stage until it goes 1 month without any problem reports. This is the kind of thing I was trying to catch before it's "complete" and all that's left is guide data adaptability.

Thanks, I just updated and have some shows to let it run against tonight.
I tried running this manually from the info in doover.sh and I am getting the output in this pastebin


I have verified that the path that it should be putting the show in is writable. For some reason it appears to be trying to put it into the movies folder as well.. any help is appreciated.