Kodi Community Forum

Full Version: [LIVE] Jerky playback of MKV Bluray
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I have noticed a few problems with my install using Beta2 and Camelot. Mostly i have MKV 720p and 1080p movies and series and i have jerky video when there tends to be alot of action or high detailed scenes such as las vegas opening from CSI. The audio does not loose sync but its not a fluid movement.

Videos are stored on Windows Home Server and streamed using HD homeplugs 200MBS, HTPC is core2duo 1.86 and 2gb RAM with onboard Nvidia 7500. I have seen youtube videos of Acer Revo running bluray with no hesitation in high def action scenes.

I have tested using the overlay whilst video playing to see CPU usage and i can see that the CPU on CPU1 runs close to max on certain parts whereas CPU0 runs 75%.

I know that on previous roll outs of XBMC live, there has been mention of CPU throttling. Is this still an issue and should i implement the fixHuh
is the issue "tearing" in the picture during fast scenes ??

i had this same problem, to fix it i checked something in settings and it got rid of it (i forgot the exact settings and i'm not at home now .. but i remember where it is)

settings -> video -> player
the setting right below render type (something along the lines of change refresh rate to video's rate)

by enabling that i got ride of my tearing issue
ok, i have enabled the setting but im still not getting smooth video! Gonna try a CSI video running from pen drive locally to see if there is any difference.
Try this (Note: This will apparently disable fancy desktop effects like Compiz):

At the terminal (CTRL + ALT + F1):
Code:
sudo nano /etc/X11/xorg.conf
Scroll using the arrow keys/Page Down right to the bottom of the file, then copy/paste or type the following:
Code:
Section "Extensions"
Option "Composite" "Disable"
EndSection
Unless you already have a 'Section "Extensions"' entry on your xorg.conf, in which case just add the following line in between the existing entries:
Code:
Option "Composite" "Disable"
Then back in XBMC, navigate over to Settings and in the Video Playback section (or whatever it may be called on your chosen skin) make sure "Sync Playback to Display" is turned on.


This solved my tearing issues, hope that helps.
Hi,

tested locally from pen drive and still have jerky video so my thought are to the setup

@Xeijin
What does this do? I thought that i had enabled the option already?
I have run a test with Crank and took a video of the results of pressing "o"

i will upload to youtube tomorrow. I have also watched a vid on youtube from somebody using a Acer revo and they show CPU usage running around 3% with no drops. Mine is hittingthe drops of around 700 frames by the time im 10 mins into the movie
From the sounds of it, you don't have enough horses for 1080p, and your GPU doesn't have hardware acceleration available.

Upgrading the GPU would be the simplest and cheapest solution.
@motd2k

Thanks for the reply! That was my thought as the FPS cannot keep at a constant rate with some parts dropping to as low as 16FPS during action scenes.

The board i recently purchased can be seen here
http://www.ebuyer.com/product/139780

This is supposedly able to cope with 1080p video?? Do you think this could be down to the driver that Live comes with? Should i SSH and include the latest build driver for my board?
FrequentRain Wrote:@motd2k

Thanks for the reply! That was my thought as the FPS cannot keep at a constant rate with some parts dropping to as low as 16FPS during action scenes.

The board i recently purchased can be seen here
http://www.ebuyer.com/product/139780

This is supposedly able to cope with 1080p video?? Do you think this could be down to the driver that Live comes with? Should i SSH and include the latest build driver for my board?

Maybe you could pick up one of the Broadcom CrystalHD cards that are now meant to work with XBMC?
picking up a ATI Radeon HD 4350 to test at home later so will see what the deal is once i have tried it. Hopefully the video will be dumped on the GPU instead of the onboard graphics
You need an nvidia card with vdpau for that, xbmc can't offload to ati cards.
please remember that GPU decoding on nvidia (VDPAU) is far more mature than on ATI (AFAIK only win DXVA)
passively cooled GT210 or GT220 boards would make much more sense, even comes with feature set C
http://en.wikipedia.org/wiki/VDPAU#Table_of_NVIDIA_GPUs
Hi

I've currently got a Sapphire ATI Radeon HD 4350 but I suffer from jerky blu-ray plackback.

From reading this thread it seems like xbmc cannot make full use of the card, which explains why both of my CPU cores hit 75% plus when I'm watching bluray videos. I had assumed the propriety ATI drivers would have enabled all features of the card to be used, but it doesn't sound like this is correct.

I was hoping someone could tell me what are the chances of getting this card to work smoothly vs purchasing new graphics card such as Asus GeForce G210

I've tried a few suggestions from various forums, such as tweaking xorg and xbmc settings but I'm not winning!

The new card is relatively cheap at around £35, but if I was to buy one I really want to be sure its going to work!

The rest of my specs (in case anyone spots another issue inhibiting playback)

AMD Athlon™ 64 X2 Dual Core Processor 4200+
4Gb RAM
Ubuntu 10.10 64bit with XBMC (xbmc-standalone)

Thanks for any help in advance Nod