Kodi Community Forum

Full Version: [LIVE] Mouse pointer doesn't go away after console access?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I'm running XBMCLive on an Acer Aspire Revo 3610.

# cat /etc/debian_version
# uname -a
Linux xbmc 2.6.31-16-generic #53-Ubuntu SMP Tue Dec 8 04:01:29 UTC 2009 i686 GNU/Linux

System Info gives: XBMC 9.11 R26018, installed onto a USB memory stick from an ISO burned to CDR. I'm using the standard Confluence skin that comes with this version of XBMCL.

Problem: Regardless of XBMC mouse setting and use of a mouse, switching from the GUI to a tty (e.g. by pressing Ctrl-Alt-F1) and back to GUI (by pressing Ctrl-Alt-F7) will always result in the X Windows mouse cursor appearing in the middle of the screen. The cursor stays visible and immobile regardless of media playback and mouse movement. If I've used the mouse before the switch, a standard arrow-shaped mouse pointer is shown. If not, then the X-shaped mouse cursor is shown instead. Again, this is the garden-variety "Unix GUI" cursor and not the stylized XBMC cursor.

Possibly related (on another platform): http://forum.xbmc.org/showthread.php?tid...e+pointers except that this pointer doesn't move with mouse input.

I would like to use the CLI for administration and setup in addition to the standard XBMC console, but the only way I've found to get rid of the cursor after using the CLI is to reboot. Is there an easy way to hide/disable this "false" cursor without recompiling XBMC? After all, it doesn't appear to be tied to mouse input anyway. Thanks!
sudo nano /etc/X11/xorg.conf

Put the following under "device" :

Option "HWCursor" "false"
Thanks for the tip. It seems the live version still uses XFree86 as there wasn't a xorg.conf but instead there was a XF86Config file. Unfortunately, /etc/init/xbmc-live.conf checks for xorg.conf so it keeps regenerating a new configuration file. I've stopped the --force-regen and added your suggested line as follows:

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
    Option         "HWCursor" "false"

Rebooting now to test.

(By the way, how do I restart X into XBMC after I use "Quit XBMC" on the GUI? It'd be nice to restart X without rebooting but simply typing "X" at the CLI doesn't work.)

EDIT: It didn't work. Switching to CLI and back to GUI shows the problem with the above edit. Does XFree86 use a slightly different configuration directive, or should I place it somewhere else in the XF86Config file? (In other words, if I'm in Xfree86 land and not Xorg land, how should I apply the configuration change?)

My live version uses xorg.conf just fine. Using ion system with nvidia driver maybe its different if you are using something like intel.

Not sure about the reboot but

"sudo service gdm start" might work
I'm on an Atom/Ion system as well. `dpkg -l` shows a bunch of X.org packages, so it's unlikely that I'm actually using XFree86.

Would you mind posting/PMing/pastebinning your full xorg.conf file (and telling me your XBMC version)? I might just try removing mine and adding yours to see if it works. Thanks again!
This is my xorg.conf.

A-ha, I put it in the wrong section. At first I didn't scroll down far enough to see a section called Device so I just used the next most obvious thing. It works great now. Thanks!
Thanks, this worked for me.

Just a word of caution to people.

DOUBLE CHECK your editing when making changes to this file, any mistakes may prevent your system from booting.

I learnt the hard way, i forgot to close the quote marks. and if your new to linux you may really struggle to recover from it without doing a reinstall.

Thanks again, fixed the issue for me.

I have just installed xbmc Dharma Beta 3 and I got into this problem. I did like calebdk said, but I think that this version didn't take care of /etc/X11/xorg.conf. The are some file in /usr/lib/X11/xorg.conf.d but what I reached is X that doesn't start.