Kodi Community Forum

Full Version: 2s silence using HDMI audio in XBMC live, not in Ubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,all

I hope someone else have had the same issue,because this is driving me nuts. And I can't seem to find any other posts about it Sad


When I enable HDMI audio in xbmc live there's 2s silence in the beginning of each song when playing music or when starting to play a movie. Skipping inside the movie also results in 2s silence.

For testing I tried to install a full ubuntu 9.1 and if I enable HDMI audio it works without the delay.

I'm guessing it has something to do with pulseaudio ? I'm currently trying to get pulseaudio working on my xbmc live install and so far no luck Sad

Anyone got any pointers as to how to get it working ?
Hmm, i have a revo 1600 and have a similar problem when the menu sounds dont start to sound until a few seconds after scrolling through the menus, wonder if its related. Havent really done much troubleshooting or testing to see if it happens anywhere else since I just got the revo on Sat and install XBMC on it for the first time.

what nvidia drivers are you running?
They're version 190.53.

Well,I was going to reinstall my xbmc live anyway to a new and faster USB key,so I decided to make a quick and dirty fix:

I installed gnome and gdm.

Enabled autologin with the xbmc user.

Set xbmc-standalone as an application to automatically launch after logging in.

Went to the gnome sound applet. Under hardware I select HDMI audio output. And now it's working. No more 2s silence. Big Grin

Ugly ..Yes..Working..YES Big Grin It will have to do for now until I figure out what's going on but it must have something to do with pulseaudio I think...