Kodi Community Forum

Full Version: Binaries for Ubuntu Lucid AMD64 ?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have the XBMC PPA added to my repositories on the new Ubuntu 10.04 'Lucid' Beta (AMD64) but there are no available files except for the CrystalHD drivers. Am I too early? Are there no binaries for my AMD64 version yet?

I realize it's possible to compile it all but I'd rather wait for a binary. Just looking for an ETA (or help if I'm looking in the wrong place for them). Thank you!
Me too.

Just upgraded my home system since the 9.10 had decided to randomly replace some bin and etc files with random gibberish ☹.
The official xbmc-svn PPA has been carrying Lucid packages for quite a while now.
JumJum Wrote:The official xbmc-svn PPA has been carrying Lucid packages for quite a while now.
Yes, but do they have AMD64 packages? I don't think they do.
bsmith1051 Wrote:Yes, but do they have AMD64 packages? I don't think they do.

I know they do. Are you just guessing? You obviously havn't even checked the repo.
http://ppa.launchpad.net/team-xbmc-svn/u...in/x/xbmc/
ah, thank you for showing me how to directly view the available files! I must be doing something wrong, then, because Synaptic doesn't 'find' anything compatible in the PPA. I added the PPA the day of the lightning strike and initially assumed it wasn't working because the whole xbmc.org site disappeared later that same day. But even since the site came back it hasn't been working.

I'll try removing it and re-adding it, per the wiki instructions (again)...

UPDATE: Aha! I just realized that you're referring to the 'SVN' PPA. I'd been using the standard (non-svn). There's no reference to this alternate PPA on the wiki page,
http://wiki.xbmc.org/?title=HOW-TO_insta...ep-by-step
I cannot access any packages for xbmc in ubuntu 10.04. I have followed both sets of instructions in the wiki (http://wiki.xbmc.org/?title=HOW-TO_insta...ep-by-step)

I am using ubuntu desktop 10.04 amd64.

So, are the packages available or not?

Thanks!

sean
qkslvrwolf Wrote:I cannot access any packages for xbmc in ubuntu 10.04. I have followed both sets of instructions in the wiki (http://wiki.xbmc.org/?title=HOW-TO_insta...ep-by-step)

I am using ubuntu desktop 10.04 amd64.

So, are the packages available or not?

Thanks!

sean

Yes, but not in that repository. You need to use the xbmc-svn repo.
Sorry to resurrect an old thread, but python addons fail for the karmic repository debs. Are you seeing the same on the lucid ones?
The recent amd64 SVN builds have a broken python24.zip, as the build packages the 32-bit version. (fyi, it's trac ticket #9491)

The best thing at the moment is to compile your own version of python24.zip.
kitlaan Wrote:The recent amd64 SVN builds have a broken python24.zip, as the build packages the 32-bit version. (fyi, it's trac ticket #9491)

The best thing at the moment is to compile your own version of python24.zip.
How do I compile only the python24.zip? A short how-to would be nice.
Yes, I haven't been able to find clear instructions on Google to compile python24.zip (yet) so a how-to would be nice.

Found a link with instructions on how to compile python24.

http://jordilin.wordpress.com/2010/05/02...ucid-lynx/
I compiled last night and it got rid of a number of bugs. I've now scripted an SVN update, make and make install keep me up-to-date in fairly short order.
GJones Wrote:I compiled last night and it got rid of a number of bugs. I've now scripted an SVN update, make and make install keep me up-to-date in fairly short order.

Hi,

I was just about to look into a script for that very thing. Would you be willing to share your script?

Thanks.

Nod