Kodi Community Forum

Full Version: Music stops but shows 'now playing' with 0:00
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I hope this is the right place to ask for help. I’ve been using XBMC on my Ubuntu 9.10 Acer Revo R3600 for a few months now without any problems. A couple of weeks ago, without me changing anything (other than running updates) a fault started appearing. I’ve tried reinstalling XBMC and fiddling around with audio output settings without any success.

When playing music from my NAS box (via smb lines in sources.xml) the audio stops after a variable amount of time (5mins to 2 hours) but XBMC still shows it as playing the track. It shows “now playing” but the time stays on 0:00 but then after approximately a quarter of the track time it changes to the next track and still shows 0:00 until it changes again. It does this regardless of screensaver settings (my initial idea of what was screwing it up).

Does anyone have any useful suggestions? This is getting very annoying as I had been using XBMC a lot as my music player and I can't understand what has changed.

Many thanks,

Andy.
I'm getting nowhere with this, does anyone have any suggestions of what I could try?

Thanks,

Andy.
Please read stickies on how to post in a useful manner. You'll get more attention when you provide the necessary details.

Thanks.
tslayer,

Sorry, I should have read that first, point taken.

I think you've put me onto something. In reading the sticky I've discovered the log file location and now I've looked at mine it contains loads of....

18:14:32 T:3055192944 M:518905856 ERROR: PulseAudio: pa_stream_get_latency() failed

....from the same time as the error occurs until the time I hit stop.

Info:
- Version = 1:XBMC 9.11-karmic1 (full metapackage)
- OS = Ubuntu 9.10 (upto date)
- Architecture = i686
- Install method = Synaptic
- SVN... sorry struggling to find this, the guide instructions don't work for Confluence
- SKin = Confluence
- Log file = http://pastebin.com/y1xQFKkh

Many thanks,

Andy.
You're almost there... That's not a debug log though. Please make sure to enable debug.
enough to see that your pulseaudio is borken somehow.
tslayer,

doh! I failed to read "Don't forget to enable debugging!" too, I'm not doing very well! Thanks for you're patience. Here's the log including debugging; http://pastebin.com/XD50Px38 note I had to cut a chunk of the repeating error lines out to make it small enough to upload.


spiff,

Yes, I'll re-install pulse audio and see if that fixes it. What's odd is I've not been messing around with the system for ages and assume it's an update that has caused this issue.

Thank you both for your help.

Cheers,

Andy.
Nope, reinstalling all the pulseaudio entries in synaptic hasn't fixed it.Sad
Searching google seems to point to perhaps a kernel upgrade or other pulseaudio issues.

You may want to try removing pulseaudio and just using ALSA.
Yesterday morning I typed "sudo apt-get install --reinstall pulseaudio" and so far it's been working OK Big Grin No idea why it had a different effect to reinstalling from Synaptic!

Thanks for the help.

Andy.