Kodi Community Forum

Full Version: Harmony Remote 555 and ION 330
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

Brain is overheating - really need some advice. Have spent the last two days browsing the forum, but I just can't seem to find an answer to this specific question.

So I installed XBMC Live onto the disk of the ASRock Ion 330. Got the drivers downloaded and confiured for the remote and everything seem to work swimmingly - until I stumbled into this:

Whenever I am browsing a file list, keeping the "scroll down" or "scroll up" button pressed, it takes on a will on it's own and seem to interpret this as if I pressed a totally different button. Sometimes it interprets it as if I pressed the left arrow, and sometimes it seem to think I pressed the "info" button.

If I scroll down by pressing the down arrow once for every new file, it kind of works.. Until it seem to get bored and start to scroll by itself very, very fast until I press another button. Then it seem to remember what it was supposed to be doing and behaves.. For another couple of presses.

Have tried everything, including changing the remote setup from MCE remote to MCE keyboard to the PVR-KLS-VDR-solution (great guide by the way) I found posted here.

All to no avail.

Please guys and girls - I need help. Either my remote or me is having a blonde couple of days. Given the fact I don't know Linux from a hole in the ground I wouldn't rule out the fact that problem resides with me, Oo but I am really, really stuck.

Have kind of ruled out the possibility of the remote being broken, since the same setup works great under the windows-build, but I just can't get the damned thing working under the Live-build, which due to speed and convenience is the one I prefer.

Any advice? At all?
How did you set up an activity for it in the first place?!!..I have the same remote and XBMClive on a Revo, but I can't get any device or activity to work!..Confused
Well.. Configured it as an MCE Keyboard, downloaded and installed the drivers for it after Live was installed to disk, and it just worked.. Can't say much more than that really. Getting the damn thing working worked fine.. But as I said.. It is being evil with me.

Can't say how to do it with the revo since I don't know what drivers to use, but for the ION I did the following:

Start with "sudo -s" for superuser.

apt-get install build-essential wget cdbs fakeroot dh-make debhelper debconf xserver-xorg-dev dkms linux-headers-$(uname -r)

cd ~
wget "http://europe.asrock.com/downloadsite/drivers/Nettop/Ubuntu/IR(9.10).zip"

unzip "IR(9.10).zip"
dpkg -i lirc-nct677x-1.0.4-ubuntu9.10.deb

At the first option during configuration I chose "Nuvoton Transceivers/Remotes" and at the second I picked "None"

Rebooted and it was accepting commands from the remote.. Although I seem to have installed a will of it's own into the bloody thing.