Kodi Community Forum

Full Version: How do I make it STOP SCROLLING!!!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am inside a wraplist and I cant get this label to stop scrolling.

Heres the code.

Code:
<control type="label">
<posx>190</posx>
<posy>15</posy>
<width>500</width>
<height>20</height>
<font>24_Bold</font>
<textcolor>black</textcolor>
<scroll>false</scroll>
<scrollspeed>0</scrollspeed>
<align>left</align>
<label>$INFO[ListItem.Label]</label>
</control>
If I recall others said this was a bug and you can't but it looks like you did it right
Using <scrollspeed>0</scrollspeed> stops the focusedlayout scrolling here.
yeah but that a hack <scroll>false</scroll> should work for consistency with the rest of the gui
Yeah I know I was just confirming that the hack worked.
Hitcher Wrote:Yeah I know I was just confirming that the hack worked.

No, it still scrolls with scrollspeed set to zero.
What build of XBMC are you using and where is the code being used?
I tried it inside of a panel list with <scrollspeed>0</scrollspeed>, didn't work.

I am using:
W7 r28202
I'm using 27527 and put the code in a wraplist.
mcborzu Wrote:I tried it inside of a panel list with <scrollspeed>0</scrollspeed>, didn't work.

I am using:
W7 r28202

Same here.
Must just something that needs fixing...

<scroll>false</scroll> or <scroll>true</scroll> works inside a wraplist but not a panel list. On 28202 atleast. Actually I had to <scroll>true</scroll> for it to scroll.
mcborzu Wrote:Must just something that needs fixing...

I seem to remember something about someone saying its a bug in post 2 of this thread Rolleyes Laugh
As far as I'm aware, the defaults are that labels always scroll in focusedlayout and never scroll in itemlayout. Setting <scroll>true</scroll> makes them always scroll in itemlayouts.

Setting <scroll>false</scroll> in a focusedlayout currently doesn't do anything. It should be the same in all containers.

If this is confirmed, I can look at making <scroll>false</scroll> do what it says inside focusedlayouts, thus allowing sane defaults as well as full control.

Cheers,
Jonathan
jmarshall Wrote:As far as I'm aware, the defaults are that labels always scroll in focusedlayout and never scroll in itemlayout. Setting <scroll>true</scroll> makes them always scroll in itemlayouts.

Setting <scroll>false</scroll> in a focusedlayout currently doesn't do anything. It should be the same in all containers.

If this is confirmed, I can look at making <scroll>false</scroll> do what it says inside focusedlayouts, thus allowing sane defaults as well as full control.

Cheers,
Jonathan

Scroll=false does not work in a focused layout. Do I need to submit a ticket for this?

Thanks for looking into it.
No, you first need to check that it's consistent across container types, and that everything else I stated is in fact that case.

Once we know that everything works consistently, I can look at fixing it - a ticket at that point for sure Smile

Cheers,
Jonathan