Kodi Community Forum

Full Version: [LINUX] Prompts for "Lock Settings" on symlinks in samba share
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
First off, system info.

XBMC machine:
Ubuntu 9.10 (as a base, just running XBMC directly without a DM)
Kernel: 2.6.31-20-generic (32-bit; it's a 600mHz CPU haha)
libsmbclient: 3.4.0-3ubuntu5
svn r26018 (I think it's just 9.11 stock? from the PPA certainly)

"Server" machine:
Kubuntu 9.10
Kernel: 2.6.31-20-generic (64-bit SMP)
samba: 3.4.0-3ubuntu5.6


Okay, so this is weird to me. My projector was dead for a few months (had a hell of a time getting a replacement bulb, and was pretty busy otherwise anyways) but I've kept my projector computer up to date in the meantime just for kicks (and sometimes briefly using my emergency backup projector). All of this means I don't know at which point things went wrong, but whereas previously this worked fine, now XBMC is unable to follow the symbolic links I have set up in the main samba share.

The only thing I can think of that's changed in the setup (since the symlinks were working fine previously) is something in the versions of the samba server and client of the server and client computers respectively, but I've been unable to find any mention of similar errors from any recent security fixes that have made their way into the Ubuntu repos (although maybe I'm just not looking hard enough). I've searched for similar errors, and following the advice of The Internet I've added the following lines to my host PC's smb.conf:

Code:
;   follow symlinks = yes
;   unix extensions = no
;   wide links = yes

but nothing seems to happen.

Oh yeah, and I've tried using other computers to access the samba shares, but it occurs to me I don't know what the expected behaviour is there; I always remember seeing the symlinks there just showing up as empty files in things like Konqueror anyways (I really only use samba for these shares). That doesn't seem to have changed, it does prompt me for user information if I try to open one of the symlinks/files but I don't know if it always did that, heh.

Checking /var/samba/log.nero (nero being the hostname of the XBMC machine) I see things like this:

Quote:[2010/04/19 02:33:54, 0] param/loadparm.c:9783(widelinks_warning)
Share 'ZEITRAUM' has wide links and unix extensions enabled. These parameters are incompatible. Wide links will be disabled for this share.

which sounds precisely like the problem. But why are unix extensions enabled when I've explicitly disabled them in smb.conf? Or if that isn't the problem, then what is going on here?

So yeah, any ideas or other troubleshooting options would be appreciated!
Ack, I was being a fair bit of a dumbass, I had forgotten that the smb.conf file is one of those config files that uses ; as a comment-out indicator too for readability. D'oh!

So, now it works since I've got the right options enabled. But, still; the log error is now even more strange, since that means somewhere other than smb.conf the two contradictory options are being "enabled" which is then resulting in wide links NOT being enabled upon the opening of the share. How is that possible, other than it being a default setting? And if it's a default setting now then that's surely a bug with samba, no?