Kodi Community Forum

Full Version: themoviedb scraper now partly broken
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
WeirdH Wrote:Confirmed working again for Xbox, made my day. Thanks to those involved!

Cheered too soon... About half of the movies get their fanart, and most of them have a smaller number to choose from than before. The fanart also seems to load slower than it did.

edit: Ah, didn't see post #45, I'll shut up already... Wink
As has been mentioned, as the cached items expire they will start to work again.

Cast info had the same issue which was corrected this morning, so by tomorrow at this time things should be working as they were before.

On a dev related note, I do feel as though it's important for apps like this to use as much standards based code as they can so that I can have a reliable idea of the behaviour to expect. The XML spec actually states order of attributes is not important.


This was compounded by using regex, which is the biggest problem. For sites that offer a real API, this doesn't make any sense. I understand for sites like IMDb that do not offer anything official, you have to. For sites like TMDb though, it defeats the whole purpose of providing a real API.

I'll leave you guys with that and of course, now make sure that as I make small tweaks to the API, that order is preserved.

Just wanted to drop my 2 cents in Big Grin
Thanks Travis. I agree, with an API I would think regex should be unnecessary...save if XBMC needs it to parse the XML. But there should be a more reliable way.

I need to get me a TMDB API key so I can see if there is a way to help out the project...

Thanks again for correcting the issues for now.
anyone still having issues? I still can't get thumbnails for some movies but fanart seems to be working again.
When you say thumbnails, you referring to movie posters?
yea, not showing up for movies like batman, batman begins
I just scanned in Batman Begins and it worked fine. Are you still having problems? If so, please post your debug log.
yea, still having issues, http://pastebin.com/vR0qvs2E
pork Wrote:yea, still having issues, http://pastebin.com/vR0qvs2E

I don't think your problem is related to this thread at all. It appears from your log that you have an NFO file in the directory, and therefore XBMC is hitting this rather than TMDB.

I would suggest creating a post on the general support subforum.

Alternatively, you could try renaming the NFO file and any thumbs cached in the directory, and then try again. Narrow down where the problem is exactly.
Thanks AaronD, that was it. It looks like I had some old .nfos leftover in some of my movie directories. I had one with just an imdb link and one that xbmc created. After removing the one xbmc created everything works again.
On Xbox I still see a problem with some movietitles that have symbols or accents in them. No fanart shows up and when I go to select it manually, this happens:

Dead Snow (originally Død snø):


Un prophète:


The thumbs load as generic images and selecting them does absolutely nothing, while these movies all had fanart before. And there's even a few movies with no special characters at all that have this problem.

Also, after fastscrolling through a list, fanart tends to remain absent until I move the cursor. What could the problem be? Log needed?

edit: I scrape movie info with imdb, don't know if that's part of the issue?
Hey mate,

Yup that's a known issue I should have fixed up this weekend.

hi its been almost a week since i done my last library update and it seems the fanart/boxart is no longer for me once again (it was broken then fixed itself a week ago) ... do i need to just be patient or is everything working and its just my setup? movies added to the library includes the karate kid, flash gordon, etc.
AaronD Wrote:A question for those more knowledgeable on regex or XBMC scraper's than me. Why is that the following query matches.

<thumb>(.*?)url="([^"]*)" width="[^"]*" size="mid"(.*?)</thumb>

But this query doesn't


The first matches because it finds the width attribute, but in the second regex I'm trying to mask out anything between the URL close quote and the size attribute. This always fails. Frustrating, because this would make it simple to take out the width parameter whether it was there or not. But my regex knowledge is very limited.

Did you try putting the .*? before size in parentheses? as in


That should do the trick

EDIT: Nevermind, parentheses only makes it a variable for capture it should have worked without the parentheses as well, I am confused


I just edited the common\tmdb.xml with the (.*?) added before size, and it seems to work (although there is currently just a space between the url and size, it should still work if there were more elements) just like jmarshall suggested.

travisbell Wrote:Hey mate,

Yup that's a known issue I should have fixed up this weekend.


travis, was this resolved? I'm still having issues getting fanart for movies with accents or symbols in the name.
Pages: 1 2 3 4 5 6