Kodi Community Forum

Full Version: Scrapers Will Not Work
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I have been messing with this problem for so long now, and i just cannot figure it out.

Simply put, my scrapers won't Scrape. I show xbmc the source, set the content, pick my scraper (since it is for movies I have tried imdb and rotton tomatos), Set it to run automated scan, and every time i press "OK" nothing happens. From what I have seen, a little box or something should pop up telling me my movies are being scraped .

Here are the things i have tired:
Smaller movie "test" folder with only 3 movies in it
Reinstalling the stable version of xbmc (Several times)
Setting content for a single movie

I guess that is all i can think of. But anyways, i have tired with the nightly build and the stable build and still get nothing.
Boxee seems to scrape just fine, but come on... Boxee, eh.

Also, if it is of any help, xbmc finds my folder.jpg art fine, but not my fan art or .nfo's.
I am also doing this on the latest version of OSX.

Please help, this is driving me insane!
First up check out the quick start guide to make sure you haven't missed anything - http://wiki.xbmc.org/index.php?title=XBM...tart_Guide

If you are still having problems:

1. Enable debug logging, make sure you are using the default skin confluence and restart xbmc
2. Do a scan.
3. Upload your debug log to pastebin or similar.
4. Confirm all of your scraping settings for your source.
5. Confirm your file / folder naming convention.
Here is the log. Its massive, but a lot of it seems to say the same thing. I don't really know the meaning though.


As far as i know, i have followed the start up guide down to the last detail, and the scrape still doesn't start.
Hopefully the log is helpful

ERROR: Can't open the database MyVideos34.db as it is a NEWER version than what we were expecting!

Looks like you have tried a newer/dev build at some point and then reverted back to the stable build. XBMC's databases are not backwards compatible so it cannot open your current db, and in turn wont be able to to write anything to it.

Delete your db and you should be good to go.
Sorry, thats excellent news, but how do i do that?

Also, is that why that whenever i would reinstall xbmc, it would remember where my source was?
iamjarrad Wrote:Sorry, thats excellent news, but how do i do that?

Also, is that why that whenever i would reinstall xbmc, it would remember where my source was?

Yes. When you reinstall / upgrade it keeps your user profile settings.

To start from scratch, just delete /Users/username/Library/Application Support/XBMC and restart xbmc
Worked like a charm, thanks a ton!
I have a very similar problem. I posted my debug log. I can't figure out how to fix it, as the TV shows scrap fine, just an error with the movies.

Hmm... It looks like the scanner is getting confused by your consolidated multipath Movies location. And I did notice that you're running a very recent SVN so please open a trac ticket.

19:39:55 T:2236 M:699084800   DEBUG: VideoInfoScanner: Scanning dir 'multipath://C%3a%5cUsers%5cHome%5cVideos%5cHD%20Movies%5c/C%3a%5cUsers%5cHome%5cDocuments%5cdownloads%5ccomplete%5cMovies%5c/' as not in the database
19:39:55 T:2236 M:699084800   DEBUG: VideoInfoScanner: Hash[movies,multipath://C%3a%5cUsers%5cHome%5cVideos%5cHD%20Movies%5c/C%3a%5cUsers%5cHome%5cDocuments%5cdownloads%5ccomplete%5cMovies%5c/]:DB=[],Computed=[6CDA408D068211B0EE19ED9BA5EFD2B1]
19:39:56 T:2236 M:699076608   DEBUG: VideoInfoScanner: Not adding item to library as no info was found :(
19:39:56 T:2236 M:699076608   DEBUG: VideoInfoScanner: Finished dir: multipath://C%3a%5cUsers%5cHome%5cVideos%5cHD%20Movies%5c/C%3a%5cUsers%5cHome%5cDocuments%5cdownloads%5ccomplete%5cMovies%5c/
19:39:56 T:2236 M:699076608  NOTICE: VideoInfoScanner: Finished scan. Scanning for video info took 00:00