Kodi Community Forum

Full Version: [BUGS] and missing items
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
zwat Wrote:1. have you fixed the possibility to remove settings from home? haven't seen any options for that on the version i got.
2. can you add files to submenu on tv-show.
3. possible to have the logo script automatically run after library update?

1. Should be there, I just checked it works for me
2. Sure
3. Thats a good idea and I would do it but since changing logos is a pain in merge versions probably best to not do it
When trying to setup a Custom Item for the home menu in Skin Settings, the Favourites dialogue is empty. When accessing Favorites from the home menu, all of the items appear as they should.

Is this a known issue? I wasn't able to find any other details on it.

Thanks,
You need the favorites script..you can grab from HERE

I'm going to look into to just adding the script to the skin like the logo script...
That was it - somehow I missed it in the faq as well.

Thanks,
I am having trouble with the "Poster" and "Showcase" views sometime after the 6/13 release. Prior to these new releases I was able. to hold down the left or right arrows and scroll my my movies rather quickly and smoothly, but now it is slow and sometimes unresponsive. I do not have extrathumbs and think this might be the culprit, but I am not positive. Here is a quick chunk from my debug log. If you need more information, please let me know and I will provide it. i am using the 6/20 release of Night and the latest nightly build of XBMC.

Code:
20:09:55 T:5548 M:4294967295   DEBUG: CImageLoader::DoWork - took 172 ms to load special://masterprofile/Thumbnails/Video/Fanart/02a407bd.tbn
20:09:55 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\/extrafanart\
20:09:55 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\../extrafanart\
20:09:55 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:55 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:55 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:55 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:55 T:5548 M:4294967295   DEBUG: CImageLoader::DoWork - took 182 ms to load special://masterprofile/Thumbnails/Video/Fanart/f1d2203d.tbn
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting V:\Movies_V\/extrafanart\
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting V:\Movies_V\../extrafanart\
20:09:56 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:56 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:56 T:6856 M:4294967295   DEBUG: CImageLoader::DoWork - took 222 ms to load special://masterprofile/Thumbnails/Video/Fanart/671330d4.tbn
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\/extrafanart\
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\../extrafanart\
20:09:56 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:56 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\/extrafanart\
20:09:56 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\../extrafanart\
20:09:56 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:56 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:57 T:6856 M:4294967295   DEBUG: CImageLoader::DoWork - took 169 ms to load special://masterprofile/Thumbnails/Video/Fanart/dbe68f9b.tbn
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\/extrafanart\
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\../extrafanart\
20:09:57 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:57 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:57 T:5548 M:4294967295   DEBUG: CImageLoader::DoWork - took 156 ms to load special://masterprofile/Thumbnails/Video/Fanart/209077f6.tbn
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\/extrafanart\
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\../extrafanart\
20:09:57 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:57 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:57 T:5124 M:4294967295   DEBUG: CImageLoader::DoWork - took 176 ms to load special://masterprofile/Thumbnails/Video/Fanart/6e38fda9.tbn
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\/extrafanart\
20:09:57 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting P:\Movies_P\../extrafanart\
20:09:58 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:58 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:58 T:6116 M:4294967295   DEBUG: CImageLoader::DoWork - took 258 ms to load special://masterprofile/Thumbnails/Video/Fanart/ea4ab3fe.tbn
20:09:58 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:58 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:58 T:6856 M:4294967295   DEBUG: CImageLoader::DoWork - took 163 ms to load special://masterprofile/Thumbnails/Video/Fanart/69c3387d.tbn
20:09:59 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:59 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:59 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:59 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:59 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
20:09:59 T:7056 M:4294967295   DEBUG: CApplication::OnKey: 61479 pressed, action is Right
20:09:59 T:6116 M:4294967295   DEBUG: CImageLoader::DoWork - took 193 ms to load special://masterprofile/Thumbnails/Video/Fanart/b2d490ea.tbn
20:09:59 T:5548 M:4294967295   DEBUG: CImageLoader::DoWork - took 175 ms to load special://masterprofile/Thumbnails/Video/Fanart/20bccd9b.tbn
20:09:59 T:6856 M:4294967295   DEBUG: CImageLoader::DoWork - took 181 ms to load special://masterprofile/Thumbnails/Video/Fanart/0c3310b3.tbn
20:09:59 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\/extrafanart\
20:09:59 T:7056 M:4294967295   ERROR: XFILE::CDirectory::GetDirectory - Error getting O:\Movies_O\../extrafanart\
20:09:59 T:7056 M:4294967295   DEBUG: SDLKeyboard: scancode: 77, sym: 275, unicode: 0, modifier: 0
No it wasnt 'extrathumbs' looks like it is 'extrafanart'...sucks to hear that, out of everything people have suggested I love this option. I really dislike skin settings but maybe I'll have to turn this into one, I'd perfer things to just work automatically...

Anyways, 100 bucks deleting these code blocks at the top of myvideonav.xml, should start at line 31, will cure the slow down:
PHP Code:
<control type="multiimage">
            <
posx>0</posx>
            <
posy>0</posy>
            <
width>1280</width>
            <
height>720</height>
            <
imagepath background="true">$INFO[ListItem.Path]/extrafanart</imagepath>
            <
timeperimage>7000</timeperimage>
            <
randomize>true</randomize>
            <
fadetime>1000</fadetime>
            <include>
Animation_BackdropFade</include>
            <
visible>![Control.IsVisible(59) | Control.IsVisible(54) | Control.IsVisible(57) | Control.IsVisible(56) | Control.IsVisible(592) | Control.IsVisible(597)]</visible>
        </
control>
        <
control type="multiimage">
            <
posx>0</posx>
            <
posy>0</posy>
            <
width>1280</width>
            <
height>720</height>
            <
imagepath background="true">$INFO[ListItem.Path]../extrafanart</imagepath>
            <
timeperimage>7000</timeperimage>
            <
randomize>true</randomize>
            <
fadetime>1000</fadetime>
            <include>
Animation_BackdropFade</include>
            <
visible>![Control.IsVisible(59) | Control.IsVisible(54) | Control.IsVisible(57) | Control.IsVisible(56) | Control.IsVisible(592) | Control.IsVisible(597)]</visible>
        </
control

My guess is what is happening is it has to wait on the drives to 'wake up' thus causing a slowdown...
Sorry. I meant 'extrafanart' and not 'extrathumbs'. You were right about the code. I removed it and it works perfectly. I don't think it is just a problem with waiting for the drives to spin up, though. Even after they are up it still is not anywhere close to smooth scrolling back and forth. It would be very nice if you could put an option in to disable this feature, but if you don't want to, I can just remove the code each time. It is no big deal to me.

Thanks for your quick help. I love this skin and "Poster" is my favorite view.
i tried the remote control of xbmc over http and it's not working good. only library items will play. in fileview nothing works. i can only brows a few folders and then i get a error message. i can see the some movie files but they won't start playing. so my question is: is this a xbmc or a skin problem?
zwat Wrote:i tried the remote control of xbmc over http and it's not working good. only library items will play. in fileview nothing works. i can only brows a few folders and then i get a error message. i can see the some movie files but they won't start playing. so my question is: is this a xbmc or a skin problem?

Have you tried it using another skin?
nah i was just about to go to bed and my keyboard was charging. can try changing today.
Just have the skin now for some days and it is a very good and nice skin.
Just one thing missing or i'm doing something wrong.

I selected to show fanart in music vis. and it works great, but if an artist has no fanart it shows the default fanart. Is it possible to have random fanart (as choosen in the home menu) as backup fanart if an artist has no fanart ??
I Noticed this a few weeks ago and forgot to post about it. That when playing music (note any type of audio file). The bottom of the screen has an black overlay that is always there. It's does not go away like (well I think it should as it does on skins I have used in the past) This is means that it hides the bottom of the visualizations (milkdrop in my case). Something to look at I think. Or maybe I am just reporting a nonBug
Roborob Wrote:Just have the skin now for some days and it is a very good and nice skin.
Just one thing missing or i'm doing something wrong.

I selected to show fanart in music vis. and it works great, but if an artist has no fanart it shows the default fanart. Is it possible to have random fanart (as choosen in the home menu) as backup fanart if an artist has no fanart ??

Thats right I have my "normal" backdrop I should choose something more music like...

Oddsodz Wrote:I Noticed this a few weeks ago and forgot to post about it. That when playing music (note any type of audio file). The bottom of the screen has an black overlay that is always there. It's does not go away like (well I think it should as it does on skins I have used in the past) This is means that it hides the bottom of the visualizations (milkdrop in my case). Something to look at I think. Or maybe I am just reporting a nonBug

I'll take a peek, music is the one section where I don't catch things as fast since I personally don't use music unlike TV/Movies which I use everyday...
Just downloaded current version of skin.night. (regular download)
I am still using svn 28256.

When playing music and browsing through movie section, in the lower right screen is the Now Playing: info with album art, etc. There is also a smaller album art with a slider showing song length and position.
They appear to be setting on top of each other. I have tried several movie views in Night with the same effect. My guess is it has something to do with the new 'show smaller music info' not knowing what to do in Movies section.

Also, when in TV or Movie section, if you view movie or tv show info, then select change thumbnail, when you browse for a new thumbnail, it only shows the Home folder and a couple more sources (I have many sources). It seems a bit of a mess and very hard to navigate. There are a couple folders showing and you have to poke around blindly (can't see them) until you find the one you want. Generally, don't all folders on the same level show up? I don't think they are here... just a list might be better like in Files view.

I have tried in other skins and not had this happen.

Lastly, In Movies, when you bring up the scroll bar by clicking the right arrow, when you click left to exit the scroller, it actually acts as if you had clicked up or down (brings up the menu at bottom of screen) rather than return you to the list of movies.

I am using an ATV with Linux and the original ATV remote.
Thanks for your efforts on this skin. It is one of my favorites!
mcborzu Wrote:Thats right I have my "normal" backdrop I should choose something more music like...

I'll take a peek, music is the one section where I don't catch things as fast since I personally don't use music unlike TV/Movies which I use everyday...

I have seen other skins where if there is no fanart, it defaults to a list that's location is defined in skin setup. Works well.