Kodi Community Forum

Full Version: [Live] Remote works in Ubuntu(non-gui) but not in XBMC :S
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My MS-tech remote works when i exit XBMC and get into the Operating System. (the dos-looking non graphic interface Ubuntu)
When i press keys on the remote i get 1,2,3 etc and even the OK button works as an Enter.
But when i go back into XBMC (or reboot) nothing registers. (not even OK which is Enter)

I'm running XBMC-live version 14 of XBMCfreak, Ubuntu 9.10, Kernel 30-20 and installed the Asrock 330ION IR receiver driver v.1.0.4.

I tried doing the following:
Quote:[email protected]:~/lirc-0.8.4a$ ./configure --with-x --with-driver=irman (or whatever remote you are using, check ./configure --help for supported ones - for homebrew serial IR use --driver=serial)
[email protected]:~/lirc-0.8.4a$ make && sudo make install

[email protected]:~# cd /etc/lirc
[email protected]:/etc/lirc# irrecord --driver=irman --device=/dev/ttyS0 MyRemote ## use the driver that you chose in the previous part. /dev/ttyS0 = first com port
I actually think i got Lirc-0.8.6 but that directory didnt exist so tried it exact as above instead.
However it didn't know the command: "make && sudo make install"
Also "irrecord --driver=irman --device=/dev/ttyS0 Myremote" didn't work either. --driver=irman did seem to be the problem as when i removed that part i did get some output.

Maybe i selected the wrong remote when i configured Lirc? As a Receiver i selected the Nuvonton and as remote None. I realise the guide i followed was for people who had the matching Asrock remote with their motherboard which i don't, could that be the issue?

Thanks in advance for any insights or advice you may have! Smile
Even if you are not sure, please share your vision on this so i can try something at least...
Let me know if you need me to supply more information otherwise.

Edited as i quoted the wrong stuff