Kodi Community Forum

Full Version: XBMC freezes after resuming paused video - just updated kernel
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running Ubuntu 9.10 Karmic with XBMC 9.11 SVN 28276 which I compiled on the machine itself. I've had it running just fine for a while now, waiting for a stable build after the addons merge. I just this week updated the kernel from 2.6.31-20 (I believe that's what I was running before) to 2.6.31-21 and then to 2.6.31-22 a few days later. Ever since I updated the kernel I have been having all kinds of issues I have narrowed down to what I think are network and buffer issues. I have solved many of the issues by rolling back to an earlier kernel (-20), but I am still having XBMC freeze at random in the menus and consistently if I pause a video and then resume it. When I pause something for a few minutes then resume it, it will play for a few more seconds then freeze completely. If I pull up the playing file info before it freezes I can see that the buffer just starts to empty once the video is resumed, like XBMC doesn't resume streaming when I start the video again.

I have tried recompiling XBMC when I am running under the new kernel, but it doesn't seem to help at all.

I was also having issues with XBMC not properly authenticating with my SMB shares, but I tried an old trick I used before of mounting the shares in fstab and then pointing XBMC at the local mount points. That seems to have cleared that issue up, but it still freezes at random when navigating and repeatedly if I pause a video.

Any ideas?
maybe a debug log will help the developers?
Did you upgrade the kernel for a specific reason?

Are the SMB shares on a Windows 7 machine? There is a specific issue with Windows 7 shares that is well-documented on the forum.

For how long are you pausing the playback? Since the issue with the shares seems to timeout eventually, this may be related.
Thankfully the issue is easy to reproduce.

Here is the full log: http://pastebin.com/Ltm1xJMJ

Here are a couple of excerpts. I have noticed this particular error comes up whenever I pause a video.

WARNING: CALSADirectSound::CALSADirectSound - device is not able to pause playback, will flush instead

And then I get a big mess of this error at the end of the log file.

WARNING: CRenderManager::FlipPage - timeout waiting for previous frame

I have compiled my copy of XBMC with --enable-pulse-audio=no and I also kill pulse with "pulseaudio -k" before XBMC is run. I haven't had any issues with ALSA before and as far as I know none of the audio settings have been changed.
I upgraded the kernel because it was in my apt list of updatable stuff. I've updated before with no issues. The shares are not on a Win7 machine, they are on a vista machine as they have been the entire time I've had the XBMC media center machine.

It only seems to happen if I pause for a few minutes. If I only pause for a few seconds it seems to continue on fine.

I just had it freeze again when I stopped a video file playing. I didn't pause it at all while it was playing but stopped it before it normally ended. XBMC went back to the menu and froze there.

Here is the log from that.