Kodi Community Forum

Full Version: How can I use ubuntu linux with time capsule support for my atv?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
How can I use ubuntu linux with time capsule support for my atv?
hellozzj Wrote:How can I use ubuntu linux with time capsule support for my atv?

install an afp client.
I used mount.cifs and mount_afp(afpfs_ng),mount_afp cannot work ,mount.cifs extremely slow, so how can I do ?
afpfs:
mount_afp afp://hellozzj:[email protected]/tc /home/xbmc/media
mount.cifs:
mount -t cifs //tc.local/BACKUP /home/xbmc/media -o username="hellozzj",password="xxxxxxx",iocharset=utf8,rw
Time Capsule and SMB info
Angrenost Wrote:I had problems using SMB with Time Capsule,the SMB client built in the TC randomly stops to work.There are hundred of reports in the Apple support forum,but the only way at the moment is to downgrade the firmware from 7.4.2 to 7.3.2.
Now is working fine so the problem is not in Snow Leopard but in TC,this problem should involve also Airport Extreme but didn't test.
To downgrade follow this,quick and easy: http://theappleblog.com/2009/05/12/publi...ule-7-4-1/
Bad,bad Apple we should ahead not back!

About AFP,i followed many many different tutorials,not result and a devasting headache! Thanks to dafranca and other people here for the help but my linux noobness is too strong i give up and leave the ball to someone more expert.
These are some link,have fun
http://www.kremalicious.com/2008/06/ubun...ne-volume/
http://sites.google.com/site/alexthepuffin/home
http://ubuntuforums.org/showthread.php?t=1011312&page=3
http://cbutera.wordpress.com/2006/05/08/...mment-1373

AFP
pin87a Wrote:The debian package for afps-ng should work.
Code:
wget http://sourceforge.net/projects/afpfs-ng/files/afpfs-ng/0.8.1/afpfs-ng_0.8.1-1_i386.deb/download
sudo dpkg -i afpfs-ng_0.8.1-1_i386.deb

Once installed you should have the mount_afp command available.
Code:
[email protected]:~$ mount_afp
Usage:
     mount_afp [-o volpass=password] <afp url> <mountpoint>

Angrenost Wrote:Then i create a dir for my TC

mkdir /home/nas

then mount it

sudo mount_afp afp://(my.tc.user):[mytcpassword]@(my.tc.ip)/Time-Capsule.local/ /home/nas

but result is always
"Mounting 10.0.1.1 from Time-Capsule.local on /home/nas
Could not pick a matching UAM."

Any idea about this recurrent error?
Must I downgrade the time capsule's firmware from 7.5.1 to 7.3.2 ? Is there any other way to solve this problem?
hellozzj Wrote:Must I downgrade the time capsule's firmware from 7.5.1 to 7.3.2 ? Is there any other way to solve this problem?

http://discussions.info.apple.com/thread...5&tstart=0

This is one of the several discussion about this problem,there is not an official solution by Apple. I was not happy about downgrade but now SMB client is working fine.
AFP would be better but i am stucked at the moment,hope i will find a way to solve it,otherwise i can stay with SMB.
Thank you! But there is another question,where can I download the 7.3.2 or 7.3.1 firmware, I have searched for serveral hours and found nothing ,the download page in apple's web site redirect to an article page. Can you send me the firmware ,thank you ?
email: [email protected]
Eheh sorry but a much easier solution was 3 post above this Rolleyes
Follow instructions here:
http://theappleblog.com/2009/05/12/publi...ule-7-4-1/
You will download fron Apple site the old firmware.
I can only select firmware 7.5.1 to upload,no 7.3.2,no 7.4.1,my airport utility version is 5.5.1
Uhmm strange,mine (5.5.1) is fine. Just to be sure,you don't have to update,open Airport Utility-in the menu bar above the desktop close to setup you should have "Airport Base" (or something like that,sorry but mine is set in italian),open the menu,Upload Firmware and choose.It will be downloaded then charged.
I did so,the only firmware I can select is 7.5.1,maybe you can find your firmware in your computer
the filename is 7.3.2.basebinary
Thank you! I downloaded it successfully.
There comes another problem ,when I upload the file ,the system told me that the firmware is not compatible for this apple wireless device.
Pages: 1 2