Kodi Community Forum

Full Version: 1080P just won't work.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I'll outline what my problem is first and then explain what I've tried thus far...

I have a Panasonic TH-P50G10A television and I'm running XBMC Live 9.11 through an nVidia 8400GS. After much mucking about (and finally reading the manual) I discovered that the VGA port will not play back anything over 1366x768.

As the 8400GS does not have a HDMI port on it, and because I've just bought a house and literally have no spare cash, I scraped together some coins and bought a DVI to HDMI cable.

The weird thing is that as the machine boots, the TV tells you what resolution it's running at as it goes. Throughout the entire boot up (motherboard splash screen, GRUB, XBMC splash screen) it says "HDMI 3 1080P".

Then magically as soon as the XBMC UI shows it's head it says "HDMI 3 VGA".

*sigh*

I tried the MythTV Modeline DB and used this modeline configuration, though I'm a bit iffy on it as the sync frequencies don't actually match what my manual says (yes I tried both):

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Panasonic-TV"
    ModelName      "P50G10A"
    HorizSync       15.0 - 68.0
    VertRefresh     23.0 - 61.0
    Option         "DPMS"
    # 1920x1080p @ 50Hz
    ModeLine "[email protected]" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
    # 1920x1080p @ 60Hz
    ModeLine "[email protected]" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    # 1920x1080p @ 24Hz
    ModeLine "[email protected]" 74.16 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +hsync
EndSection

With the above configuration added to xorg.conf it won't boot into XBMC, I just get the Linux terminal.

Can anyone shed some light on why the actual XBMC application reverts to crappy 640x480, when even the terminal window runs at 1080p? Any suggestions would be wonderful...I really don't want to fork out for a new card with HDMI when the current one works fine.

Hopefully someone can help me out. Thanks in advance.

Regards,

- Matt
Try xmbcfreaks builds of live they include a few tweaks that might or might not help with getting the correct resolution.

There is also an SVN build of the next version of XBMC here, worth trying out either one at least and see if it works.
check jumjum's thread:

http://forum.xbmc.org/showthread.php?tid=70068

this solved all my problems. Doesn't even have to use modelines anymore to get 1080p with my panasonic TV.
I'll give JumJum's method a try. I'll run the script first and if I get no luck I'll try the manual method. I would like to give the nightly SVN builds a go, but my whole setup is built around XBMC live (for simplicity sake) so that's a little problematic.

I'm sure if I have no luck i'll be back lol!

Thanks for the links.

Cheers.