Kodi Community Forum

Full Version: praise & some small bugs (if i am not mistaken)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
hi,

first of all, i love this skin. it is clean, unobstrusive, and does a beautiful job of conveying most information by means of simple typography. definitely by far my favourite.

however, a few little things bug me.

first, if you go video -> browse -> [align=left], you get a configuration menu for the file view. it has a double entry, meaning basically that there are two entries on top of each other.

second, i am using eventghost to send events to xbmc from a remote. in play mode, hitting [blank] on a regular keyboard to toggle pause mode works, but sending the XBMC:pause event from eventghost does not. it does, however, work in other skins.

third ... how do i get a menu to select audio- and subtitle track while playing video?

fourth, when browsing, "previous menu" or "parent dir" always bring me back to the home screen. so, if i go:

home -> video -> browse -> [source1]

and then press "previous menu"

i would actually expect it to go back to "browse", while in fact it goes back to the home screen.

fifth, while playing a video, the main menus are superimposed over the image, but as soon as i enter the filebrowser, the video disappears. this might be intentional for better readability, but i think it is a bit inconsistent.

sixth, when going

home -> video -> now playing

pressing "left" doesn't bring me back to the "video" menu, but instead brings up "now playing" detail config. this is the same in the file browser in my first comment. maybe it would be better to assign this to "right", so that "left" is free to do what i would consider consistent behaviour: bring back the previous menu.

now, these are little problems, i think. but i think improving these would mean a great improvement to the overall user experience. again, thanks for the great work so far Smile

.rm
rubenm Wrote:hi,

first of all, i love this skin. it is clean, unobstrusive, and does a beautiful job of conveying most information by means of simple typography. definitely by far my favourite.

however, a few little things bug me.

first, if you go video -> browse -> [align=left], you get a configuration menu for the file view. it has a double entry, meaning basically that there are two entries on top of each other.
Which entry would be displayed double? I checked my version and the public release version but I can't see it, or I misunderstand what you mean. Could you post a screenshot?

Quote:second, i am using eventghost to send events to xbmc from a remote. in play mode, hitting [blank] on a regular keyboard to toggle pause mode works, but sending the XBMC:pause event from eventghost does not. it does, however, work in other skins.
I'll have to investigate this one. I would assume this should not be skin related, but I have a hunch about what *might* be causing it.

Quote:third ... how do i get a menu to select audio- and subtitle track while playing video?
By bringing up the OSD while playing a video. Then hit the audio button and you will be able to change these in the dialog that pops up.

Quote:fourth, when browsing, "previous menu" or "parent dir" always bring me back to the home screen. so, if i go:

home -> video -> browse -> [source1]

and then press "previous menu"

i would actually expect it to go back to "browse", while in fact it goes back to the home screen.
Seems like a configuration issue of your remote. "Previous Menu" will in this cade indeed always take you to the homescreen. You will need to use the button that holds the "Back" action. This is not skin specific.

Quote:fifth, while playing a video, the main menus are superimposed over the image, but as soon as i enter the filebrowser, the video disappears. this might be intentional for better readability, but i think it is a bit inconsistent.
There's an option in skin settings->view settings to enable the video to be displayed in the background. This is a separate setting next to the option for the homescreen. It will however be obscured by the interface. This is indeed to keep it readable.

Quote:sixth, when going

home -> video -> now playing

pressing "left" doesn't bring me back to the "video" menu, but instead brings up "now playing" detail config. this is the same in the file browser in my first comment. maybe it would be better to assign this to "right", so that "left" is free to do what i would consider consistent behaviour: bring back the previous menu.
This really is a matter of either using or configuring the remote properly. The "Previous Menu" and "Back" actions are tied to buttons on your remote. "Left" and "Right" are intended for navigation within the currently displayed screen and not for navigating between screens. So if I were to assign these actions to left and right I would be duplicating functionality. Besides that, pressing right to get to a menu on the left isn't what I would consider intuitive. Also, the "Right" button is also used to get to the scrollbars. You'll find that there's no skin around that uses the approach you are describing.

Quote:now, these are little problems, i think. but i think improving these would mean a great improvement to the overall user experience. again, thanks for the great work so far Smile

.rm

Thanks Smile
Jeroen Wrote:Could you post a screenshot?

here you go:
Image

Jeroen Wrote:I'll have to investigate this one. I would assume this should not be skin related, but I have a hunch about what *might* be causing it.

i tried having eventghost emulate keystrokes, but no cigar ... only the hardware keyboard's [space] will toggle pause

Jeroen Wrote:By bringing up the OSD while playing a video.

ayah! i always tried the "Context Menu" command, never saw that OSD thing. works fine, looks great, and even lets me pause!

Jeroen Wrote:Seems like a configuration issue of your remote. "Previous Menu" will in this cade indeed always take you to the homescreen. You will need to use the button that holds the "Back" action. This is not skin specific.

what key would that be? i can't find XBMC:Back in the eventghost plugin, but could i add it? i don't know ... basically, eventghost will just send udmp to 9777, right?

Jeroen Wrote:You'll find that there's no skin around that uses the approach you are describing.

it seems that i misunderstood the concept ... i thought of the interface as having 4 directions, or two dimensions, with left<->right always translates to less specific / more specific, and up <-> down translates to choosing among the items in the current context, and also determines the actual meaning of any subsequent "more specific" action. but, unfortunately, these things are usually more complex, and from experience i can say that unless i actually start doing a menu model, i would probably not be able to fully understand the problems that arise ....

anyway ... i still have two more things i forgot to mention: radiobuttons in selected menu entries are not very readable ... and i had a weird situation that i haven't been able to reproduce where i tried to enter a username in the network settings, the on-screen keyboard came up, but didn't get the focus, so any arrow presses just moved the cursor in the text field ...

in conclusion - using the osd to work around the pause thing, i now feel more comfortable using this than any other skin. lovely.
rubenm Wrote:here you go:
Weird. Does this happen all the time? Are you using 0.8.1 and not the version that was released at first? I'll try some more to reproduce it.

Quote:what key would that be? i can't find XBMC:Back in the eventghost plugin, but could i add it? i don't know ... basically, eventghost will just send udmp to 9777, right?
It's whatever you assign this action to in your keymap. I don't know anything about the eventghost plugin, can't help you there I'm afraid.

Quote:anyway ... i still have two more things i forgot to mention: radiobuttons in selected menu entries are not very readable ...
I know. The problem here is that I can only assign textures to "On" and "Off", and not to focused and unfocused. I think I'll be making a request for the xbmc devs for this, as this has been bothering me too.

Quote:and i had a weird situation that i haven't been able to reproduce where i tried to enter a username in the network settings, the on-screen keyboard came up, but didn't get the focus, so any arrow presses just moved the cursor in the text field ...
I think disabling "remote control sends keypresses" in system settings->input devices should help you there.

Quote:in conclusion - using the osd to work around the pause thing, i now feel more comfortable using this than any other skin. lovely.
Great Smile